Thread: Support Milestone XT720 Frustration
View Single Post
Old February 16th, 2011, 10:28 AM   #1 (permalink)
OrlandoFC
New Member
Thread Author (OP)
 
OrlandoFC's Avatar
 
Join Date: Feb 2011
Location: Orlando, FL
Posts: 7
 
Device(s): Motorola Defy, Motorola Milestone XT720
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Exclamation Milestone XT720 Frustration

Noob with an XT720 in the US.

When I first got it the phone was ultra slow and glitchy. My friend asked for it back, said she was going to perform some updates. She did, and I was able to use my T-Mobile SIM card in it and make calls/texts/MMS.

I was more excited than I've ever been about the phone, seeing as how no one in the US has it.

It worked beautifully for two days, then, all of a sudden, out of nowhere, the phone stopped recognizing the SIM card. At least this is the story my wife told me when she ran the phone to me and told me it stopped working. I might not know what actually happened (she learned how to do a master reset the first time around with this phone as we were trying to figure out the issues ourselves, before we sent it back to my friend who eventually performed update 1 on 2.1, which made it work).

Still able to connect to Wifi and everything, just won't recognize the SIM card.

I finally did a master reset, and definitely screwed myself. I guess my friend changed the APN manually to the T-mobile settings, and resetting the phone erased them. I looked up and tried so many different APN settings it's not even funny. I finally gave up and bought a Defy (which, btw, I freggin LOVE!), upgrade my contract and got it for $50. Didn't have a data plan when I first started using the XT720, but got the basic data plan when I bought the Defy.

I was hoping I could troubleshoot my SIM card issue using settings from my Defy or something. Seems like a pipe dream after a month or two of this frustration. Any tips or advice anyone may have is welcome.

I'm sitting at work without an assignment and have both my phones in front of me with a usb connect, and it's my first attempt to carry out my master plan (which, admittedly, I have no idea will work. I'm a technical person, so it's not a total shot in the dark. But still, phones aren't usually my thing...).

Oh, one more thing I should mention, my friend gave me the phone out of pity for me, and she said it was a demo phone that came from Japan. When it didn't work initially she thought it was likely do to settings related to demo phones not being configured for regular use. Like I said earlier, whatever she thought was the issue she fixed, as it was working for a few days.

Any help you can provide would be appreciated, and I'll post pics/solutions/whatever relating to this so that in the future, people like myself can figure this phone out. Because an 8MP camera is a horrible thing to waste...
OrlandoFC is offline  
Last edited by OrlandoFC; February 16th, 2011 at 10:29 AM. Reason: took out profanity
Reply With Quote