View Single Post
Old January 22nd, 2010, 08:17 PM   #72 (permalink)
britbloke
Junior Member
 
Join Date: Jan 2010
Location: Kitchener, Ontario
Posts: 81
 
Device(s): LG Eve iPhone 8GB 3G
Carrier: Not Provided

Thanks: 0
Thanked 12 Times in 3 Posts
Default

I'm a brand new owner of the LG Eve (well, my wife is technically!) and I was very disappointed when I heard that the Eve can't be updated to 1.6 or 2.0 when I contacted LG support this morning. They said the reason it can't be updated is because the Eve is a combination of Android with S-Class.

I really hope that the comments here will help spur on the LG team to further develop. Maybe I've been too used to my iPhone and it's constant updates. It seems like we're being given the short straw again from Rogers.
britbloke is offline  
Last edited by britbloke; January 22nd, 2010 at 08:21 PM.
Reply With Quote