View Single Post
Old February 10th, 2010, 09:45 AM   #6 (permalink)
Chickenhead
New Member
Thread Author (OP)
 
Join Date: Feb 2010
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well big surprise...called Robbers and ONCE AGAIN was told I'm "not eligible" for something. So i'm "not eligible" for the Magic update.

Let's add that to the list...I "wasn't eligible" to upgrade my stupid Treo. I "wasn't eligible" for the replacement program even though the damn thing's bluetooth was hopelessly broken. But they were more than happy to stick me with another 3-year contract even though they wouldn't give me a phone to go with it.

But this didn't stop the sales idiot from trying to hook me into a "pre-authorized payment program." Of course. I call about one thing, and they use it as an excuse to hook me into something completely un-related...hey Rogers, this kind of bullshit is what I expect (and get) from Bell.

Anyway, to hell with Rogers. I hope you're not holding your breath that Rogers will actually upgrade your Magics to 1.6 or 2.x someday. You may be shocked to find it "not eligible." Or some other excuse--they've got a million of them. But don't you dare question their almighty 3-year contracts! I may just spend the money to entirely cancel my rogers "contract."

So to answer the question, YES: any phone I get henceforth will be rooted, unlocked, and untied. And probably not on Rogers. I don't find them "eligible" for my support in any way at this point. (Hey RogersMary, feel free to pass this on to your supervisors, not that they're likely to give a shit.)
Chickenhead is offline  
Reply With Quote