View Single Post
Old December 9th, 2011, 10:39 AM   #17 (permalink)
thewick
New Member
 
Join Date: Dec 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 3 Times in 2 Posts
Default

Quote:
Originally Posted by thewick View Post
I am having the EXACT same problems - I need to remove the battery to get the phone to respond, and my battery is draining way too fast. All since the latest upgrade a few days ago.

Help!

EDIT: Also, I noticed that the phone is not powered off when it goes blank/unresponsive, just apparently can't see/use the screen/buttons. I tried calling my phone in its unresponsive state and it rang, but no display on the screen/button response. And iff I plug in the phone to charge, it makes the phone charging 'beep' tone, but again no screen display/buttons until I reset the phone by removing the battery and powering on again...
Well I think I FIXED my problem. It ended up being Google Maps causing the problem. I uninstalled Google Maps, turned the phone off, turned it back on, reinstalled google maps, and now it is all acting fine. Phone hasn't gone blank/unresponsive, battery is draining normally, and overall it seems faster than before the update now. Google Maps was the issue. I know others are having different problems, but for those getting the battery drain / blank screen; reinstall google maps.
thewick is offline  
Reply With Quote
The Following 2 Users Say Thank You to thewick For This Useful Post:
rgcazo (December 20th, 2011), shapleigh91 (December 9th, 2011)