View Single Post
Old December 14th, 2011, 06:36 PM   #32 (permalink)
akazabam
Senior Member
 
Join Date: Jun 2010
Location: Near Los Angeles
Posts: 4,418
 
Device(s): Samsung Galaxy Nexus
Carrier: Not Provided

Thanks: 101
Thanked 1,387 Times in 1,051 Posts
Default

Quote:
Originally Posted by ocnbrze View Post
AKAZABAM is in the house. you have been sorely missed my friend. good to see that you are alive and well. please feel free to pop in at anytime. i always look forward to reading your posts.

and that sucks about your phone. hope that goes well for you.
Thanks . I'll try to pop in a little more often. I haven't been keeping up on as much as I used to, so others are probably of more help than me. My phone is fine, btw. It booted up this morning just fine, and everything works. I guess it eventually happens to everyone.

Quote:
Originally Posted by dustwun77 View Post
Howdy! I am trying to follow your directions, running into some snags.

I ran the first command and got the a2sd.out file, can't upload it here because .out not an accepted extension. I renamed it to .txt, hope it still works for you.

It looks to me like the second command is waiting for me to give it some sort of permission that I do not Know how to do.

Let me know what else you would like me to try.

Thanks.
Sorry, my fault. .txt is fine. As for the second command, that is exactly what I expected to see. /system/sd/ is the mount point for the ext3 partition on your sdcard, and /system/sd/app in the directory that contains all your apps that the normal app location (/data/app) is pointing to via a symlink. If none of that made sense, I think I've probably done a better job explaining it in other posts

As for the output from a2sd check, I'll post each applicable line here and explain what it means:

[✔] Programs run from SD card
To run from internal storage, type a2sd remove

This one is pretty obvious. It means a2sd worked, and apps are now on the sdcard ext3 partition, as confirmed by that second command you ran.


[✔] Private Programs run from SD card
To run from internal storage, type a2sd remove

Same as the above, but with /data/app-private being symlinked to /system/sd/app-private. It means it worked.


[✔] Dalvik runs from SD card
To run from internal storage, type a2sd nocache
To run from /cache partition, type a2sd cachepart

This means dalvik cache is now on the sdcard ext3 partition, as well. If you run a2sd nocache, it will undo it, entirely for dalvik cache. Personally, I prefer to run a2sd cachepart. This means that dalvik cache will move back to internal storage, but in the /cache partition, which is mostly only used as a temporary holding place for downloaded apps (and a few other things). It's basically wasted spaced. Dalvik cache is normally kept on the /data partition, which will take away from your usable space. If you move it to /cache, you get the benefits of freed up space, but it runs a tad faster since it's on internal storage. That's just my opinion.


Swap - [ ] Partition not present or no swap support.
[✔] Swap does not start.

You can ignore this. You don't need a swap partition. swap is used in a traditional system as overflow for when you run out of RAM, basically. That's a simplified explanation, but you don't need it on a phone, really.



As for some of the other output, here is a quick explanation of what I think you'll find important to know:

EXT Partition - [✔] Mounted
Mount Point - [ ] /system/sd
Partition Type - [✔] EXT3

That first part means the ext3 partition (identified as ext3 filesystem type in the first part, there) is indeed mounted, and the second part means it is mounted at /system/sd. That means if you were to use a file browser or the terminal emulator and browse to the /system/sd directory, it would look like part of the normal file system, but you'd actually be looking at files on the sdcard. That is where the app directory has been created, and symlinked to. You saw that in that second command you ran.

On a quick side note, I think this output confuses a lot of people:

[ ] No Apps2SD Flag File not found.

That is a really poorly worded statement. It should look more like this:

"No Apps2SD Flag File" not found.

A flag file is a file that exists solely to tell some program or another that something is in a particular state or that it should behave in a certain way. In this case, this flag file would exist if you were to use a2sd to move your apps back to internal storage. If you did, this flag file would be created. It's been a while since I looked into some of the a2sd scripts, but if I remember correctly the flag files basically exist in order to tell the a2sd startup scripts (in /system/etc/init.d) whether or not it should create the necessary symlinks at startup to look on the sdcard for your apps.

In case you didn't feel like reading all that, it means it's working fine.


If you want even more output to confirm that it worked, run this from the terminal emulator:

df -h /system/sd

or if busybox doesn't like that:

df|grep /system/sd


As for other apps not saying anything about apps being on the sdcard, don't trust them. For one, a2sd is "special". Unless an app knows to look at /data/app and realize it's a symlink "shortcut" to the sdcard ext3 partition, it'll just think apps are on internal storage. That's the point of a2sd. It makes android think you now have more internal storage. It even fools some apps into giving your wrong information if they aren't a2sd-aware. The issue is further confused by the fact that android supports moving some apps to the sdcard in a limited fashion. This is not the same thing. That leaves part of the app on internal storage, and moves the non-executable part that it can to the fat32 partition on the card. It also disables widgets. A2sd doesn't work this way, and the android system, in general, thinks apps are still on internal storage when they really aren't


Did that help clear anything up, or did I just confuse the issue more?

EDIT:

Oh, and if you're using an aosp ROM, the mount point for the ext3 partition is likely /sd-ext, not /system/sd, so if you ran:

ls -l -d /data/app

it would look like this instead:

app -> /sd-ext
akazabam is offline  
Last edited by akazabam; December 14th, 2011 at 06:38 PM.
Reply With Quote
The Following 6 Users Say Thank You to akazabam For This Useful Post:
argedion (December 15th, 2011), dustwun77 (December 14th, 2011), Granite1 (January 4th, 2012), Mikestony (October 6th, 2012), MizzouBrent (December 14th, 2011), ocnbrze (December 14th, 2011)