View Single Post
Old March 14th, 2012, 08:47 PM   #1 (permalink)
RShea
New Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default Droid 2 Global and Rooting/SuperUser issues

I have a Droid 2 Global running Android 2.3.4 (system version 4.5.629.A956.Verizon.en.US) and it was rooted before using the Motorola One Click Rooting app. Worked fine allowing me to run apps that required root access like Titanium Backup (not Pro), and most importantly Droidwall to control the access of applications on 3G data. I also use 3G Watchdog to control apps access over 3G vs wifi. Since the last round of updates (Google Play downloaded to replace the Android marketplace, etc.) I have had reports that the phone is not rooted (most recently via trying to install Titanium Backup update. I have Super User showing and the 3 apps listed are the SuperUser, Droidwall, and Titanium Backup.

Just to be safe I also just redid the Rooting with Motorola One Click that I used before to root the device (which does in fact state for 2.3.4 in the application box when launched) in January. When I launch Titanium Backup 4.8.4 it reports "Sorry, I could not acquire root privileges. This application will *not* work! Please verify that your ROM is rooted and includes BusyBox, and try again."

I did download BusyBox and it also is reporting that the Installer was not allowed root access (there are 2 BusyBox and BusyBox Installer and I did both)

I also downloaded Root Check Basic and it too reports that this device does not have proper root access. I also tried the SuperUser Update Fixer and it reports no problems but if I force the fixer to run it failed and recommends downloading updater.zip from SuperUser web site.

Any ideas on this. Fortunately the Droidwall and 3G Watchdog seem to be working and controlling the 3G data still. I'd like to get the Backup going again, since I can't use the Verizon Backup Assistant due to being on PagePlus prepaid....
RShea is offline  
Reply With Quote