View Single Post
Old March 22nd, 2012, 04:33 PM   #21 (permalink)
Techno79
Junior Member
 
Join Date: Sep 2008
Posts: 23
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

My phone was working fine with my Google Apps Domain account but then I had to change my Google password on my PC. A little while later, I get a Google Talk Authentication Failed notification message. When I click on it, I get a Retry or a Cancel option. Neither of which allows me to enter the new password. I have tried the steps above but still exactly the same issue. I can't believe there is no way to change the password on the primary Google Account.

I ran into the same issue a while back when I attempted to enable the 2-step verification feature. I thought it was the 2-step verification feature that was broken but it now appears like it's the inability to change the primary password on the Google Account on the phone.

It is so annoying as the only way that I was able to fix it was to do a hard reset and enter the correct password during the setup of the phone.

Surely there must be another way to do it?
Techno79 is offline  
Reply With Quote