Thread: General exFAT or ext3 Support
View Single Post
Old May 4th, 2012, 10:37 AM   #1 (permalink)
WoodburyMan
New Member
Thread Author (OP)
 
Join Date: Apr 2012
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 1 Post
Default exFAT or ext3 Support

I have a 32gb Class 10 microSD card I am using with my tablet. I have a few movies that are already in h264/aac format that the tablet can play. However I ran into a issue. These files are 4.5gb in size. The default format for my microSD card is FAT32. FAT32 has a limitation where files cannot be larger than 4gb each.

I sought out to see if our tablets support any alternative file systems.. and the results are not promising

I used a USB adapter and PartedMagic / gParted to format the card. First I tried ext3, since its linux native and Android is in essence linux so I thought that would work. No luck. After formatting, putting it in the tablet, it states "Preparing SD card for use" then "You may not eject your SD card" messages right after each other and it will not mount.

I then did the same, except with a Windows box, and formatted the microSD to exFat. (exFAT is a acceptable use as it supports large files as well and works in MacOSX and Windows which I both use on a daily basis). Pop it in the tablet. Same thing.

Reformatted back to FAT32.. works but but no greater than 4gb support.

Are we stuck using FAT32 or is there another way around this? I am rooted and if there's something I can try I can give it a shot. Or am I stuck having to recode my movies to a just slightly lower bitrate so they fit?
WoodburyMan is offline  
Reply With Quote