View Single Post
Old June 17th, 2012, 05:23 PM   #10 (permalink)
speedycolzalez
Senior Member
 
Join Date: May 2010
Location: Getting satellite fix...
Posts: 513
 
Device(s): Samsung Galaxy S2, Samsung Tab 10.1 3G, HTC Desire
Carrier: Not Provided

Thanks: 21
Thanked 70 Times in 54 Posts
Default

Quote:
Originally Posted by billyjean View Post
On my rooted tmobile samsung galaxy s2 that is now running on the latest ics firmware, I deleted some useless apps, and accidentally, twlauncher was one of them. I basically cant do anything on my phone now. What can I do to solve this problem? Please help, as I need to be able to use my phone asap.

Also, I tried downloading the new firmware for my phone on the sammobile website, but after like 10 minutes, it says "failed." I'm really worreid that my phone is totally gone..


Thank you so much.
You may be better off starting a new thread as this one is solved according to the title.

What 'failed'? The download? You'll just have to keep trying till you get a successful one.

You could try downloading from one of the threads below depending on whether you want carrier branded or rooted firmware.

[ROMS]Official i9100 carrier branded firmware download for Odin Flash - xda-developers

[ROM+Guide]Official i9100 Firmwares LPE/Q/7/2/F/S/4/7/G/9/W/D/F Download - xda-developers

The second thread also includes a guide showing how to flash with Odin.

If the Odin flash failed you'll need to give more details to get help.

HTH.
speedycolzalez is offline  
Reply With Quote