View Single Post
Old June 23rd, 2012, 01:25 PM   #1 (permalink)
dannyb91979
New Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Droid X Bluetooth issues with Alpine deck

Hi all,

I just bought a new Alpine CDE-W235BT. I know it doesn't offer Android control, but it should be able to stream standard a2dp audio without trouble. It works beautifully with a couple HTC phone's I've troubleshooted with, but it will not work properly with my Droid X.

Here's what happens: I pair the phone with the deck, open either Google Music (the cloud music player - not the stock music app), or Pandora and it begins to play the first song without issue. As soon as the song is over, or I press the skip button (on either the phone or the deck), the deck displays BT A PAUSE on the display, and the phone continues on and plays the next track as if nothing is wrong. However, the BT A PAUSE does not go away, and no more music plays unless I change sources and come back to Bluetooth, then it reconnects and continues on until the next track is over. (I tried this on the CDE-133BT in the store too, and got the same exact problems)

On the HTC phones I experimented with, it displays BT A PAUSE while the phone loads the next track, but it goes away and resumes playing as soon as the next song begins, and the song plays correctly. This is what SHOULD happen.

The first thing I did was tried another rom, and even restored the stock rom and unrooted it - this did not fix the problem. Reading some other threads, I thought maybe it was a problem where it was trying to play with the stock music player (some phones have an issue playing two sources), but I don't have any music stored on my phone, so was hanging up, so (I'm rooted), I uninstalled the stock music app and the music storage service. This seemed to fix the problem temporarily - it worked during ONE pair with the deck, but then went back to it's tricks the next time I paired it. I also tried loading a media storage service apk and a stock music apk from an HTC phone with no cigar. Then I tried uninstalling the bluetooth apk and tried loading the one from an HTC phone with also no change (The bluetooth apk from the HTC wouldn't even install, and uninstalling the stock one didn't seem to make a difference).

I also changed the audio.conf in the /system/etc/bluetooth directory to increase the connections to 3, and master to true with no change. Any suggestions to get this to work, other than to get a new phone??

Thanks in advance!
dannyb91979 is offline  
Last edited by dannyb91979; June 23rd, 2012 at 02:40 PM.
Reply With Quote