View Single Post
Old July 8th, 2012, 09:25 PM   #107 (permalink)
Greens
New Member
 
Join Date: Jul 2012
Posts: 12
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 5 Times in 4 Posts
Default

EarlyMon, I took my 1st EVO 4G LTE in yesterday to the main service center at the Campus Store at Sprint headquarters here in Kansas City area. The Asst Mgr, Alex Walter, insisted that there is no way to check the RF on the LTE phones right now, and he checked with other technicians on the phone to confirm. He said there are no Sprint locations in the country that can check RF on the EVO LTE until some updates to their testing equipment are rolled out. Not sure I believe him, but he and all his tech crew were very insistent that it simply isn't an option anywhere in the country. Where exactly are you getting RF tests done on EVO LTEs?

They gave me a new EVO 4G LTE but I still am seeing horrendously low speed and terrible signal reception. Speedtests for past days on both phones have ranged primarily from 26k to 150k, with occasional bursts all the way to a whopping 350k. That's small k, as in barely better than dialup! And I continue to have signal drops while others at the same location are having no probs on their phones. I seldom if ever had signal issues on my old phone. I can't risk being stuck with a phone this completely unusable so am returning it tomorrow. Nice it's working for some, but if you travel much I'd be worried. I'd love the phone if it would just work as it should. Sad.
Greens is offline  
Reply With Quote
The Following User Says Thank You to Greens For This Useful Post:
EarlyMon (July 8th, 2012)