View Single Post
Old August 6th, 2012, 04:12 PM   #24 (permalink)
scotty85
AF Addict
Thread Author (OP)
 
scotty85's Avatar
 
Join Date: Jul 2010
Posts: 10,657
 
Device(s):
Carrier: Not Provided

Thanks: 7,194
Thanked 6,786 Times in 4,268 Posts
Default

Quote:
Originally Posted by obscuro View Post
Scotty usually works til around 5, maybe he can help better when he gets off.
sorry guys,i dont know if i have anything real useful to add,im new to these OTAPkgs myself they were taken from the cache partition of my phone immediately after downloading. i dont think either contain info that is specific to my phone,but i could be wrong.

Quote:
Originally Posted by obscuro View Post
Scotty, I managed to perform the first update, but can't get the second (stage2) update.zip to work.

The first one seemed like it got picked up automatically through hboot,
hmm,hboot started the update? how did you have it named? "update","Update",or "UPDATE"? it could be that my s-off phone didnt do some security check that your s-on phones are doing.

after the update,did you check your build number? did stage1 take you to 2.01.605.12?

Quote:
Originally Posted by obscuro View Post
for the second one, I started stock recovery and chose the apply update from sdcard option.It gave me the cache error and then said it was rebooting with error:
Invalid operation
success rebooting by reason oem-00

any ideas?
none,whatsoever. if the first update worked,im not sure why the second would fail.

unless the first update didnt really work. but in that situation,i dont think youd have picked up the second stage via wifi,as youd have still been on 2.01.605.11. the OTA should have porompeted you for the 7mb one,if the first one hadnt really worked.

you did wipe cache with the stock recovery before chosing update from sd card?

Quote:
Originally Posted by obscuro View Post
EDIT: Do you have to be locked? My installation of the mini-RUU worked just fine, got GB up and running, just FYI. Cleared the cache and dalvik cache, like u said. I do have superuser 0.94 installed, and flashed Setmainverlow.zip.
no,i dont believe you need to be locked or relocked. my s-off phone was unlocked,and i have defiantely accepted OTAs while unlocked and s-on,so i wouldnt think this to be any different.

Quote:
Originally Posted by obscuro View Post
EDIT3: I tried flashing Setmainverlow.zip again, then trying to install update2, still didn't work. Going to see if I can get the OTA on the phone connection.

EDIT 4: Got the OTA over wifi, so that's good. Still don't know why it wouldn't work manually.
i actually would have thot changing your main version with the mainversionlow.zip would have been somewhat counterproductive,as i dont know how the updater scripts check for release firmware. changing the main version in the misc image may confusion,as other places that list the build number wont match it. but again,since you got the 2nd stage to download and apply,it must not have mattered much.

Quote:
Originally Posted by obscuro View Post
Earlier I had an issue when restoring the data part of my most recent backup. It sent stock GB into bootloops and I had to clear storage. My goal is to be running ViperRez with my data restored. My most recent backup is from newts, so I just want to make sure there are no conflicts, as long as I don't restore boot/system/cache.
newts is a different build alltotheger(inc 4g,not rezound),different framework,different sense version. im not surprised restring data from newts to stock GB sent it into a state of confusion.

in otherwords,yes,id think there to be conflicts! you can only restore your data back to the same rom.

Quote:
Originally Posted by darksideofjae View Post
At the beginning of the "Update1" portion I get this error
--Invalid Operation. --
Success Rebooting by reason: oem-00...
had you run the mini ruu?

were you competely stock?any apps frozen or deleted?

you were on build 2.01.605.11,correct?

youre using the stock recovery to try and wipe cache,and flash update.zip,correct?


Quote:
Originally Posted by darksideofjae View Post
Yup, deleted the cache and the davlik cache.
this comment makes me think you were maybe not using the stock recovery,as it does not have option to erase dalvik cache. only factory resert,and wipe cache

again,sorry guys. im not really sure why its not working correctly. i did this exact procedure to my phone twice(and a few failed attempts prior) so i thot since OTAPkg was a signed by htc file that you s-on'ers should have any prollems.

hopefully we can figure it out,as i was really hoping to to find an easier way for the folks that werent getting the prompt,or had failed attempts.
__________________
The Delivery Guy
If someone has helped you,please click the THANKS button on that post.
Please post questions so others can benefit from the answers.
donate to my device fund
scotty85 is offline  
Reply With Quote