View Single Post
Old August 7th, 2012, 04:48 AM   #5 (permalink)
Mana619
New Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Mana619 View Post
---------------------------------------------------------------------------------------------------------------
I cannot delete Uno nor can I delete BubbleBash!

Lovely for all of you that just state, "worked for me! I deleted this and that!"

I am only a user of Android for about a year now and a Linux user for about a year and a half. I am a programmer, but hardware is very different. New hardware, new this, new that... it is hard to keep up if you don't have tons of free time.

Checklist I have:
-Rooted my phone? Don't ask me how or where, but I downloaded some software to my PC that some genius gave to all of us and rooted my phone and I even installed an app to check if it was rooted. LOL! Then this Android Terminal app was installed that su seemed to work so I am pretty sure like pure gold 99.99999% I am rooted. Thats 5 nines, not 4! If you have ever purched gold bullion you will get that one.
-I am indeed a Rooted user or SuperUser on my phone now.
-I tried z4Root or whatever it's called... nada... reinstalled? Not on the AppStore anymore. Didn't work anyway.
-Tried finding my way to these apps via USB and Linux (Kubuntu) using terminal commands and nada!
-Installed an Android Terminal to my Androind phone. This seemed like the only way to really find these apps.
-Huawei Ascend ii by the way is my mobile device.
-Titanium blah blah.. seemed pretty useless
-ES File Explorer - nada - unable to uninstall Uno nor BubblBash
-Tried the Android Terminal and did all the different methods I could find to mount and remount with rw.. i.e. (e.g. if you wish - just as BC v. BCE) ---
$ su (enter)
# mount -o rw,remount -t yaffs2 /dev/block/mtdblock4 /system (enter)
# rm BubbleBash.apk
or # rm -r BubbleBash.apk
same problem ("read only file.. can't do... blah blah blah")
-Still when rm -r BubbleBash.apk (in the /cust/cricket/us/app dir.) read only cannot unistall / fail etc message.

So I am at my wits end trying to do this "oh so easy" uninstall with Root SuperUser crap!

So is this Huawei Ascend ii just a special device that has no "work arounds"? Work around with no description as it were...

Also keep in mind all of the stuff that I see everyone just spouting off is software and that software was designed by the real wizards. I wouldn't call myself a novice to Android, but I am not an expert either. I can find my way around. I know some terminal stuff too.

So how about it? Anybody up for putting in a little time to help out?

Much, no, GREATLY APPRECIATED to anyone who would help out.

THX!

E.
Turns out I finally, finally got it done!

I was determined not to be defeated... and it so happens that I got it.

-Step 1: I noted that my Android OS was 2.3.6, and for some reason while doing research I was convinced that I had to have version 2.3.3 OS for my Android mobile phone. So I googled downgrading OS. I really don't know what the names are, you can google them; they are something like gingerbread, icecream sandwich, jelly bean.. I mean whatever right? So I followed the instructions to save this file to my SDCARD on the first folder in the directory (root folder).

-Step 2: I Rooted my phone (Huawei Ascend ii) - using a piece of software I found somewhere that worked for me ( I will update this after I find where I saved it :-/ ). This is actually a big step. The software I downloaded was saved to my PC. It was magic really and it rooted my phone.

-Step3: Now Rooted! I installed Android Terminal to my device via App Store (FREE).

-Step4: Got frustrated because I could not now uninstall UNO and BubbleBash! Still not able to delete these bastard useless files!?!? Did some research.
-
-FINALLY!
-put together some things I read about rw (read / write) privileges.
-the Linux Expert was here:
-
http://android-tricks.blogspot.com/2009/01/mount-filesystem-read-write.html
-
-Note: after you figure where your *.apk files are using the Android Terminal (linux commands).
-- you will find out that the Expert's command:
--------$su (super user command)
--------#cat /proc/mounts (to find out what blocks have "ro"-read-only or "rw"-read-write )
----------read through the results after this command
--------I found out that on Huawei Ascend
--------------------the BubbleBash_311.apk and UNO_314.apk are in /cust/cricket/us/apps directory
--------------------and the correct command on my phone to get the correct blocks to rw ready
--------# mount -o rw,remount -t yaffs2 /dev/block/mtdblock8 /cust
-
Done!!!
-
Now #rm BubbleBash_311.apk --- works! Gone gone gone!
AND #rm UNO_314.apk
-
-
So from the hint on that link above:
#mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system
----works for apps in the /system directory only and when you use the #cat /proc/mounts, command
---------you will filter out where you need to make the adjustments for this line command example.
-
-
-
Feel free to ask anything or comment.
-
I know some about a lot of things and I don't know everything about all things. I am an expert in a lot of things that people don't use but I am catching up to modern hardware and modern software. Thank GooDness for internet and forums. Can you imagine going to the library to study the manuals or writing letters to the engineers?

E.
Mana619 is offline  
Last edited by Mana619; August 7th, 2012 at 04:51 AM.
Reply With Quote