View Single Post
Old August 15th, 2012, 01:30 PM   #10 (permalink)
sg3geek
New Member
 
Join Date: Aug 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I found a solution that worked. Below was the method I used, followed by further explanation. You may not need to follow these steps exactly, but they're the steps I used.

1) Plug Samsung Galaxy S3 phone into computer's USB port. You will get the MTP driver failed to installed message.

2) Backup SMS / MMS using a backup app (like MyBackup Pro).

3) Factory reset phone (while still plugged into computer).

4) Do NOT sign in to your Google Account when phone resets - This is CRITICAL. You can do it later.

5) Basically, just get the phone started up again without signing into any accounts (like Dropbox, Samsung account, etc.)

6) MTP driver should have automatically installed on computer - if not, then unplug phone from computer and reconnect.

7) Sign into your Google Account, and feel free to re-customize your phone at this point.


Explanation and Notes:

1) I factory reset my phone 2x in a row. The first time, without doing ANYTHING on the phone after factory resetting it except for signing into my Google Account, the MTP driver failed to install. I believe this happens because signing into my Google Account uses the "backup and restore" functionality of the Google Android account and Google starts automatically downloading saved settings like home screen, Wallpaper, Play Store apps, and other settings. This interferes with the initial MTP driver installation. The 2nd time I factory reset (within minutes of the first factory reset), I did NOT sign into Google Account, and voila, the MTP drivers installed. Only AFTER I was able to connect to the computer did I sign in to Google Account.

2) Previous to this solution, I had tried every solution I had found online including:

a) checking / unchecking USB debugging mode
b) toggling between MTP mode and Camera mode
c) changing some hidden Android settings
d) using different USB cables (the one that came with the phone along with others I had)
e) uninstalling and reinstalling the Samsung drivers
f) uninstalling and reinstalling Samsung Kies
g) Device Manager in Microsoft Windows - deleting everything under Universal Serial Bus Controllers so it would reinstall upon Windows restart
h) cleaning registry
i) trying to connect to different computers (it didn't work)


I had initially thought it was a computer problem, but then realized I was using MTP to connect other devices (like a Sony videocamera). The problem was with the Google Account automatically downloading various settings to the phone (because of the Backup and Restore functionality) PRIOR to connecting to the computer.


For those of you who have tried everything suggested online to connect to the computer, I hope this solution helps!
sg3geek is offline  
Reply With Quote