View Single Post
Old August 31st, 2012, 04:30 PM   #1 (permalink)
nagash13
New Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy help with RockChip (mebook) reader anyone?

Hello!
I bought an ebook reader,with system RockChip RK2738 SDK (version 1.1.1 touch) before a week.It's the chinese one,with many brand names,like Mebook Reader as the most well knowned.
From the first time using it,since now,it shuts down after 3 minutes (although I didn't select that option) and after that all my data are lost!
The weird thing is that all settings are lost too,except the date and time..
I tried to contact the seller,and the only thing he could tell me in english was to format it-which I tried,with no luck several times,unless I do it wrong!
I tried to contact another seller with chinese products,and they suggested me to do a factory reset,but they don't know how that can be done (no such setting)

Can someone tell me what can I do,or if there's a possibility to change firmware to make it work? (and how that can be done?)
Any suggestions welcome!

Thanks in advance!
nagash13 is offline  
Reply With Quote