View Single Post
Old September 12th, 2012, 06:59 AM   #42 (permalink)
000bit
New Member
 
Join Date: Sep 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 2 Times in 1 Post
Default

I have some updates.
So this -> Rikomagic MK802 Forums • View topic - CWM Recovery Installation + CM9 & CM10
doesn't work (or at least I couldn't make it work, didn't test it much).
You will be able to install cwm, but the screen will be split in 4 subscreens flickering as soon as you move the mouse/keyboard.

This -> Rikomagic MK802 Forums • View topic - THE MK802 II Recovery How to, Tools, Firmware and Benchmarks works, using phoenix card you can restore to a proper firmware, but not CM10 (for now).

TO INSTALL CWM on MK802 II:
Get this -> https://www.miniand.com/forums/forums/development/topics/clockworkmod-recovery-5-5-0-4-livesuit-image
Use phoenixcard and burn as product the recovery image. Booting the mk802 with the card inside will basically screw the boot process (yes, the correct solution would be creating a valid image, but I didn't have time and/or experience).
Now REMOVE the card and reboot the mk802 II. Because the boot stage is screwed the mk802 will enter recovery mode and BE ACCESSIBLE WITH LIVESUIT.

Get livesuit or livesuit64 according to your operating system from here -> How to re-install MK802 firmware - Liliputing. Burn the clockworkmod-recovery-5-5-0-4-livesuit-image from the first link using livesuit as it was supposed to be.

You should have a full screen, with no flickering, version of CWM and the mouse should work properly, too.

Now, because with screwed everything with the phoenixcard, a factory reset/wipe IS NECESSARY (no backup is possible). You can format the card to normal and use it to install CM10 and compatibility zip, otherwise remember to REMOVE the card before rebooting or it will screw everything again.

The result? The CM10 boot screen will appear spinning on the screen, BUT it will be stuck forever (because probably we need another compatibility zip).

SO, if it was not clear from the multiple times I said you're screwing the boot process, DO NOT DO THIS. IT IS STILL NOT WORKING.



Note for the devs, I tried extracting the recovery.img from the cwm-livesuit and writing to /dev/block/nandg, but the flickering issue is still there, I wonder if the boot.img of the livesuit img is necessary as well, or maybe on mk802 II recovery is on nandf? I need to extract the contents of the official mk802 II firmware and compare, but I didn't have time. Is the compatibility zip for mk802 also valid on mk802 II?
000bit is offline  
Reply With Quote
The Following 2 Users Say Thank You to 000bit For This Useful Post:
dbshane (September 12th, 2012), kozmo2k4 (October 4th, 2012)