View Single Post
Old September 23rd, 2012, 12:31 PM   #10 (permalink)
Hadron
AF Contributor
 
Hadron's Avatar
 
Join Date: Aug 2010
Location: Dimension Jumping
Posts: 12,485
 
Device(s): HTC One (S-Off), HTC Desire (retired)
Carrier: Orange UK

Thanks: 2,306
Thanked 5,243 Times in 3,768 Posts
Default

Either way, thing to check is that (a) the network branding (if any) corresponds to the original phone, and (b) it either says "Froyo" or the radio has "_5." in the string - anything "_4" is Eclair, and it would be perverse to install that!

Also, check it says "RUU" at the start of the name, not "OTA".

But as to which, actually why not the 2.3 upgrade? If it's so the friend can get used to Android before buying their own, they certainly aren't going to be buying Froyo. Of course using any sort of stock is also getting them used to HTC Sense as well as Android.
__________________
Forum Rules & Guidelines - Android Forums FAQ
If a post helps you, use the Thanks! button.
Spam or offensive? Don't respond, report it /!\
Hadron is offline  
Reply With Quote
The Following User Says Thank You to Hadron For This Useful Post:
shauny13 (September 23rd, 2012)