Thread: Support Can't Install Applications
View Single Post
Old October 7th, 2012, 12:19 PM   #1 (permalink)
PeterMcC
Junior Member
Thread Author (OP)
 
Join Date: Jul 2011
Location: London, UK
Posts: 17
 
Device(s): Samsung Galaxy S2
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default Can't Install Applications

A few applications have disappeared from my SG S2 in recent days. I have tried to restore these from a Titanium backup but it doesn't work. The restore seems to start but it never completes.

I have tried to restore them from the Play Store but I get an error message saying that it can't do the restore. "Error: Couldn't Install on USB Storage or USB.

There appears to be plenty of internal, SD and External_SD.

I am not aware of any errors on these devices but don't know how to resolve the situation.

I recently updated my S2 on Kies I9100XXLPQ and rooted the phone. I haven't noticed any other issues.

Peter
Attached Images
File Type: png Screenshot_2012-10-06-18-10-53.png (156.4 KB, 5 views)
PeterMcC is offline  
Reply With Quote