View Single Post
Old October 9th, 2012, 08:48 AM   #33 (permalink)
BSH
Junior Member
 
Join Date: Apr 2010
Posts: 56
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 4 Times in 4 Posts
Default

Quote:
Originally Posted by mgaylor View Post
I'm hoping you guys can help. i bought a used DX off ebay that already has .621 on it ive downloaded and burned the cd and have tried to root my dx several times but the first thing it says is rm failed for /data/preinstall_md5/magic md5/magic.md5. No such file or directory. and then proceeds thru the rest of the rooting process saying the installation everything else has failed. Any thoughts???
I ran into the same thing. If you followed the steps exactly, and the phone went through the entire process, you should find Superuser among your apps, and it should be rooted. You can try downloading Titanium Backup, which requires root to work, or Bootstrap (for Droid 2 NOT Droid X) which will install recovery where you can flash other roms, which also requires root. If they don't work, you don't have root. After going through this process a half dozen times in the past two weeks, I no longer notice the warning you notice above, because it doesn't matter.

My understanding is this: the rooting script is trying to remove a directory that it needs to be gone before it can root. If the directory isn't there, it can't remove it (hence, rm fails), but since that directory isn't supposed to be there, the rest of the rooting process works. I'm a newbie, not a hacker, so I may be wrong. But I went through the same thing, and I've now rooted this phone several times in the past couple weeks with the method described in this thread.
BSH is offline  
Reply With Quote