View Single Post
Old October 13th, 2012, 09:00 AM   #1 (permalink)
marlinlutes
New Member
Thread Author (OP)
 
Join Date: Jul 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default screen flashing black as signal changes???

a friend of mine sent me this email out and I am having the same problems. I copied and pasted it to see if anyone has any solutions.


Hey I have recently started having a weird issue with my Galaxy S2 Whenever it changes network modes (ex: driving in a car as it switches between EDGE, 4G, and LTE based on coverage in area) it causes the screen to go black for a second. It happens while in any app, like if I'm browsing, the screen will flash black for about 1 second then back to whatever I was viewing as it switches networks. If the phone is on the home screen and switches network modes, the home screen will rotate to landscape mode and appear to be zoomed in and then go black before switching back to portrait - which is very weird because stock touchwhiz does not rotate home screens.

I have done a factory reset and gyro calibration and still have same issue. If the phone isn't switching network modes it works 100%.

I'm running ICS 4.04. Phone is not rooted.

Any thoughts???

PS - this issue is especially annoying because at my house my phone gets weak LTE signal so it switches between 4G and LTE frequently. Yes I can prevent this by changing the network settings but I find this problem troubling; is it hardware or software???


my response back...


Mine is doing the same thing. Only much worse than yours. Mine started doing it about 2 weeks ago. Mine is also now freezing up crashing and rebooting and screen going black for a couple minutes but (just frooze up for 2min). Always comes back to exactly where I left off. Weird?? sometimes the homscreen will stay rotated for hours before (fixing itself). I have also reset phone and got a new sim card with no luck.
marlinlutes is offline  
Reply With Quote