View Single Post
Old October 27th, 2012, 10:25 AM   #9 (permalink)
Fru1tbat
New Member
 
Join Date: Oct 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Danalee26x View Post
Ok, I've read through this thread and I'm still looking for answers. I bought my prime in January and it was working great. It even survived a 3 week jaunt across Europe. Anyways, about two weeks ago, the prime wasn't charging up anymore. I plugged it into the charger that came with the tablet, and used the original connecting cable (as I have been since I got the tablet), but could not get led light on to indicate charging. I turned on the tablet to see if the power widget indicated it was charging, nope. So I figured, ok, maybe the cable was faulty, so I ordered a new one from Amazon, it arrived today, but it still doesn't charge. So does anyone know what is going on or do I have to ship it back to ASUS for repairs? Any help would be appreciated. Thanks
Try putting the charger in the freezer for a few minutes. I know it sounds silly, but the charger has an overtemp sensor for safety/user annoyance, and once it trips, it needs to be cooled down before it will work again. Worked for me a couple times. (seriously)
Fru1tbat is offline  
Reply With Quote