View Single Post
Old November 13th, 2012, 05:21 PM   #1 (permalink)
wildetudor
Junior Member
Thread Author (OP)
 
Join Date: Apr 2011
Location: Romania
Posts: 64
 
Device(s): Samsung Galaxy S2 (previously: Nokia N85)
Carrier: Not Provided

Thanks: 34
Thanked 0 Times in 0 Posts
Default Vectone UK: data & SMS not working in roaming (+zero customer support)

Hello everyone,

My Vectone pay-as-you-go works fine in roaming for calls, however SMSs don't get sent, and the H+arrows icon never appears next to the signal bars, indicating the lack of a data connection.

This is despite the fact that
- in the UK (home network), both data and SMS work fine
- (as per Vectone's instructions) I always restart the phone after reaching the roaming country, as well as select the "Overseas" option from the Vectone menu
- the phone (Samsung S2) has all the right settings for data connections, and the "data roaming" option is enabled
- I have used both automatic network selection, as well as manually tried getting onto every single available local network (Vodafone, IWIND etc)

It is unbelievable that I have to resort to asking this in a forum instead of Vectone's customer service, which is so incompetent that my (literally) dozens of calls and emails reporting this problem have not helped with anything. The only suggestion they gave me is that my account should have at least GBP 10.00 in order for data to work in roaming (which was true every time anyway).

I read other posts (but no suggested solutions) of people reporting problems with data and SMS simultaneously, so perhaps there is a common source for both problems?

If anyone could suggest any fixes (assuming this is not just a general fault from Vectone's part), I'd be really grateful!
wildetudor is offline  
Last edited by wildetudor; November 14th, 2012 at 04:13 AM.
Reply With Quote