Thread: help with 7za
View Single Post
Old November 15th, 2012, 06:30 PM   #6 (permalink)
argedion
The TechnoFrog
Thread Author (OP)
 
argedion's Avatar
 
Join Date: Jun 2011
Location: The Severed Garden
Posts: 5,526
 
Device(s): HTC EVO 4g(Retired), HTC EVO LTE(Retired), LG Lucid(Returned), Motorola Droid Razr M, Nexus 7
Carrier: GOD

Thanks: 5,567
Thanked 5,325 Times in 2,470 Posts
Default

Quote:
Originally Posted by 9to5cynic View Post
Shoot. Maybe 7za and 7zr are not as similar as I thought....

How is your archive directory set up? Is it all files in one directory - or are there multiple directories?

Hmm... What error are you getting? That same one with Incomplete command or whatever it said?
as a test I was doing ~/Downloads/temp I had a zip file in temp along with some other regular files everytime I do something similar to this

7za a temp.7z ~/Downloads/temp -x!*.zip
I get the error of it still zipping the zip file if i add the " r -x!" then i get incorrect command

IF I SHOOT IT THEN I GET A INCORRECT COMMAND WITH A CRACKED SCREEN.


@Early
Yeah I have done that I have done -ax I have put it up front of the commands, behind them and still get the same thing either it will make the archive adding the zip file or it gives me the incorrect command error.

Basically when I zip up the contents from my SDCARD in the phone I want to archive everthing except for the stuff that is already in archive format. no need to compress that stuff again. I guess I may have to go through and remove the zips before I run my bash to zip the sdcard up. I was going to put this in conjuction with my other bash that copies the entire content of the sdcards using adb command.
I was going to automate the process of compressing those backups and removing everything from the original except the archived files that were there. I could then rsync to an archived folder those files and then delete the source files and finally delete the empty directorys.

Sounds simple right???????
__________________
All My Links In one Convenient Place
Asking simple questions can keep us from doing dumb things.
argedion is online now  
Reply With Quote