View Single Post
Old November 18th, 2012, 08:25 AM   #83 (permalink)
akkidroid4u
New Member
 
Join Date: Nov 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hey Guys! Hope you are up for reading my looooooooong post (plus rant)!

Need some help with my SGS2. I am facing similar problems as what seems like for millions other!

THE ISSUE: My phone keeps crashing randomly after my ICS update, and when it does the battery indicator shows a steep drop in charge. So this happens even when I have 85% battery charge, and on re-boot battery shows 35%... 50% of the battery seems to have pulled off a Houdini's disappearing act in a flash!

SOME FACTS:
1. I have a sim-free version of the SGS2 in the UK... and I know this is a T-Mobile thread...but really liked the discussions going on here thats why my post...
2. My phone is NOT rooted (and I do not intend to root it either)
3. I have upgraded to ICS using KIES v2.4, they have rolled out a KIES v2.5 just recently (after my upgrade), according to which I have the latest firmware too...
4. My phone: model number GT-I9100, Android version 4.0.4, Base brand version I9100XXLQ6, Kernel version 3.0.15-I9100XWLPT-CL941023 dpi@DELL169 #3

The Story so far:
Post my upgrade to ICS, my battery started draining rapidly, like others have experienced too, it went from lasting 16 hours (with the things I do) to less than 6 hours. Thats where the alarms started ringing, and I started my online search for a solution. First I tried the battery re-calibration (just like what Juo78 suggested). Well the next couple of days battery was back to the same old 16 hours lasting... so I was like EUREKA! problem solved!!! just when I started celebrating and started playing my fun HD games, my fone started crashing... for no rhyme or reason, it would just shut down and that to when i was about to beat my own high scores!!! Grrrr! well anyway, on reboot it would show a sharp decline in Battery usage anywhere between 35 to 50% drop... if I continued playing regardless, then in less than a minute battery would be down to 0-1%... so i tried the battery calibration again, but no difference in the behaviour. I then decide to live without my 'life changing' games... and battery usage was back to normal (it even felt better lasting than before at times)... I then decide to play non HD games (assuming that the HD games are probably conflicting with the 4.0.4 OS... but same problem occurs again... and got worse... even while browsing net, facebook, twitter, it would randomly shut down... so my next diagnosis is resource availability issue! I jump to the conclusion that too much going on in the background and I came across the suggestion that you can limit background processes to zero by changing the setting in DEVELOPER OPTIONS.... again EUREKA! it worked for a couple of days... but the problem returned much to my annoyance... Finally I had to do it - FACTORY RESET... so I backed up all my data and applications using KIES... I was so hoping that I do not need to erase my stuff... but had to bite the bullet... I restored only my contacts, messages and call logs... everything else was re-done... I installed every application again from the market again (not from my back up)... did that work?? HELL NO!!! I am still stuck with the same issue... battery usage seems fine when doing basic stuff on my phone... the 2-3 situations when it crashes are either when I am playing some heavy games, updating multiple apps from Play store, and once it happened while watching videos on youtube... my current feel is that resource availability is an issue, so i am now trying JuiceDefender to see if that helps... if that does not work, the next thing on my list is BetterBatteryStats... because honestly I don't think JuiceDefender works the same way as BetterBatteryStats (but I could be wrong)... I will try to upload a screenshot of the battery usage indicator... coz it did something very strange the last time it booted... my phone went from 76% before crash to 33% after boot... but then it was rising...without charging it! so I did a reboot after a few minutes and it was then showing as 63%! I mean what the hell was that! Oh one thing I should mention is that every time it crashes, I take the battery out completely, wait for 30 secs to a minute and then put it back in... because i think that helps...
So anything else that anyone can suggest will be highly appreciated!

Some constraints for potential solutions to my issue:
1. I love ICS, its fantastic when it works, in fact I love it so much that I am not going back to GB at any cost, so I will even live with this if I have to... but would of course prefer not too...
2. I am not rooting my phone, have not done it till date and do not intend to in the future... frankly because I do not think I have it in me to handle a rooted fone.

If nothing, I hope you get a good laugh out of my experience and if you have experienced this, just know that you are not by yourself!!

But hats off to all you guys who are participating in these forums! They are absolutely PRICESSLESS! I will definitely post an update if my situation gets sorted!


Cheers
akkidroid4u is offline  
Reply With Quote