View Single Post
Old November 23rd, 2012, 06:09 AM   #77 (permalink)
newnexus7
New Member
 
Join Date: Nov 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Needachange View Post
And it started working again.......thank God!
Here is what I did:
Removed the back cover. Did it with my finger nail. I was looking for some place to insert my nail in and the cover actually popped out a bit. Form there onward, it was a piece of cake.
Disconnected the battery (checked ifixit website for that).
Reconnected it.
Pushed the power button and it turned on.
Battery is at 100% coz it remained on charge overnight.
So that was all about resetting the battery.

Thanks a million to everyone who helped.
Thanks a Zillion......Brought a new Nexus7 32 GB today..When i switched it on, the battery was showing a warning.. i plugged in the charger and the icon shows a flash symbol implying it is charging but the charge stays at 0% no matter how long i charge it....if i remove the charger the battery warning sign re-appears and i don't know if there is any charging left in the battery at all nd it switched off a couple of times...... after trying to charge with different USB cables including the stock charger..nothing worked...shows up as charging when plugged in..batter stays at 0% (in the settings it actually says not able to determine the battery's current staus !) as a last resort followed your advice...opened the back cover with my nail and disonnected and reconnected the battery cable (the cable was not properly/fully into the leads inside..i guess that was what the original problem was)..restarted the tab...now it shows 100% battery ..solved the problem 100%. Saved me from the hassle of returning it back and waiting for the new one !
newnexus7 is offline  
Reply With Quote