View Single Post
Old November 25th, 2012, 09:17 PM   #1 (permalink)
Nightlasher
New Member
Thread Author (OP)
 
Nightlasher's Avatar
 
Join Date: Nov 2012
Posts: 3
 
Device(s): ZTE Blade
Carrier: China Unicom

Thanks: 0
Thanked 0 Times in 0 Posts
Notsure China-Bought ZTE Blade Can't Use Google Play Whatsoever

Well, about 6 months ago, I bought my first Android, a ZTE Blade, in China. I was kinda bummed that it didn't come with Google Play, but it did come with several Chinese markets that had a fair selection (and all free). However I still wanted Google Play. I tried downloading it off external sources (at least 4 different sites), but even though it normally would be installed, it would never even boot up. It would force close the moment it was opened, and I couldn't ever find any support. I could find similar cases, but never any solutions that worked. My "expert" friends couldn't help, Google Support couldn't help (since it was bought in China I guess), and I finally gave up. Anyway, I recently started back trying to get it, and I could access it from my phone's browser, but it never recognized I was on a mobile device, and I couldn't download anything. Just a little while ago, I got an app called Google Play Services, which I hoped might help (as it was a passive app that couldn't be opened, and I thought maybe it would allow Google Play), but Google Play still wouldn't work. I'm getting sick of this, and don't want to have to fork over a few hundred dollars for a new phone (My phone's got plenty of problems, like it can't use Flash Player or install anything above 40 MB, but they're bearable aside from not being able to get Google Play). And yes, I have cleared my cache, reinstalled, restarted, factory reset, cleared data, used different versions and different sources. So anyone got some tips?
Nightlasher is offline  
Reply With Quote