View Single Post
Old December 17th, 2012, 07:55 PM   #1 (permalink)
cased3448
New Member
Thread Author (OP)
 
Join Date: Dec 2012
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default buyer beware: SanDisk class 10 32 gb does not work well with the triumph

Hey guys,

So I've done extensive testing ever since swapping in a new sandisk 32 gb sd card I bought on amazon. I cant link yet but the exact product is:
SanDisk Ultra 32 GB MicroSDHC Class 10 UHS-1 Memory Card with Adapter (SDSDQU-032G-AFFP-A)

I cannot flash roms using this card or restore a nandroid. It basically bricked my phone, and I ran here to get help a few days ago (got that fixed after I started using my old sdcard)I thought its because I was formatting the 32gb card on my computer so I tried to format it in my phone, it took forever and resulted in a "damaged" card (lots of folders with weird symbols show up when I reinsert the card into the computer).



When I try to use a rom, which was stored in internal memory after it was flashed from my older sd card, many apps force close (especially google services framework, which is critical... and i need to reboot with a battery pull) and the phone itself is very sluggish and feels unstable.



As soon as I pop in my really old 2 gb class 4 sdcard, or even my 8gb class 6 sdcard, the phone works normally.



I am using the U9000 ROM, but the issue occurs in cm7 and sharp rom.


Do others have issues with this card, or did I get a defective one? If so how do I return it/replace it because I threw away the packaging thinking I that a brand new SanDisk card sold via Amazon could not possibly be faulty.



However, the card works just fine and is super fast if I use it as a normal sdcard for just the computer. I got the "frustration free" shipping option since its cheaper, not sure if the retail packaging version would be different.
cased3448 is offline  
Reply With Quote