View Single Post
Old December 19th, 2012, 07:24 PM   #65 (permalink)
clh42
Junior Member
 
Join Date: Dec 2012
Posts: 16
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

I haven't had my SD card die entirely yet, but I've had random issues with it since day 1. Got an S III on the Sprint black friday deal, and got a SanDisk Ultra 64 Gb SD card off of Amazon.com.

I never see the "unexpectedly removed" message, but I see 3 issues regarding my SD card. So I either have a faulty SD card, or the phone has issues. But if I put the micro SD card in a regular SD adapter and plug it into a card reader on my computer it looks and works just fine. So I DON'T think it's the card.

1. After powering off the phone and back on, it will, probably about 75% of the time (but not always), tell me that that there's an issue with the SD card and want to reformat it. I skip the reformat and instead I go into Storage Settings and mount the card. It always mounts, but then sometimes I see what I'll mention in # 2 below (it's mounted but no files present) and I have to unmount and mount the card again.

2. Even though the card technically stays "mounted" it will suddenly act as if it's empty. I usually find this because I will go to access music or pictures on the card and it can't find them. then I go into My Files and it shows "No Files" on the entire card, like it's blank. I unount and remount the card, some times I have to do this 2 or 3 times though, and it comes back and shows the files.

3. With the card validly mounted and properly showing files ON THE PHONE itself (per # 2 above), if I connect the phone to my computer via USB and try to browse the card using Windows Explorer on the computer, I can see SOME files, but not other files that I KNOW I copied to the card previously. I had copied some music, pictures, ringtones, and notifications sounds to the SD card previously, but now when I attach the phone to the computer via USB and try to browse it on the computer, the ringtones and notification files don't show up (I see the directories on the card but when I go into the directory it appears empty). But on the phone I can still see them in the My Files browser on the phone, and I can select the ringtones or notifications I had copied to the SD card in the phone Settings, so the phone itself knows they're there.

I have tried twice reformatting the card in the phone and recopying my files to the card, but these problems always return. I read somewhere to try formatting it on a PC (by using a card reader on the PC to use the card directly instead of through the phone) so I tried that. Same issue. I read somewhere to try formatting it using FAT32 instead of the exFAT that the phone uses (I think it's exFAT64 that the phone uses if you format it in the phone, or something like that) and that didn't help either. So now I'm back to having formatted with the phone a 3rd time and still see the issues.
clh42 is offline  
Reply With Quote