View Single Post
Old December 31st, 2012, 05:14 PM   #5 (permalink)
jordan443
Junior Member
Thread Author (OP)
 
Join Date: Dec 2012
Posts: 15
 
Device(s): HTC One X
Carrier: Rogers

Thanks: 2
Thanked 0 Times in 0 Posts
Default

I just tried to mount the sdcard using this guide:

If you don't have an sd card, or your slot is broken you can try this trick, but you will need a custom recovery like Clockwork.
Boot up your phone to recovery. And move your rom file to the adb directory, and start a command line ( cmd )
adb shell
mount data
adb push D:\custom_rom.zip /data/
Wait until the push finised, and restart your device to recovery again with "adb reboot-bootloader"
mount data
mount /data /sdcard ( mount the data folder into your sdcard folder, so your recovery will think that you have an sdcard installed )
Locate the ROM .Zip file you wish to flash.
Confirm the flash by following the on-screen instructions (ie: pressing the trackball, pressing the call button, etc.)
If no errors arise during the flashing process then the ROM flash was successful, Reboot the device.
With some root file explorer, remove the rom file if you don't need it anymore, to free up space.
Or use adb to remove the custom recovery
adb shell rm data/custom_rom.zip


i ended up getting this error:

Jordan:OneXRootTools Jordan$ ./adb-mac shell
* daemon not running. starting it now *
* daemon started successfully *
~ # mount data
mount: mounting /dev/block/mmcblk0p35 on /data failed: Invalid argument

I tried it again after partitioning the drive to FAT32, still didn't work

I also tried to flash the ROM vie fast boot and got this:

Jordan:OneXRootOneClick Jordan$ ./fastboot-mac flash zip PJ83IMG_Evita_UL_Rogers_WWE_1.73.631.1_Radio_0.16a .32.09.06_10.81.32.14L_release_254934_signed.zip
sending 'zip' (590714 KB)... INFOstart check_usb: usb_ep0: type=128, request=6

INFOstart check_usb: usb_ep0: type=2, request=1

It seems to be stuck there
jordan443 is offline  
Last edited by jordan443; December 31st, 2012 at 05:47 PM.
Reply With Quote