View Single Post
Old January 8th, 2013, 12:03 AM   #59 (permalink)
rockstead
New Member
 
Join Date: Jan 2013
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Please Help, My Liquid E isn't working since Rogers/Fido 2.2 update

Guys, I think I totally messed up my wife's phone and I'm in trouble, I really need some help here.

I have a Acer Liquid E, it was previously on Fido and it had 2.1 on it and my friend gave it to me and it worked fine on Roger's just by placing in a Roger's Sim Card.

I went to Acer.Ca and I followed the instructions to apply the Froyo 2.2 update, I placed the update.zip and the image folder on the root of my SD card and followed the procdedures for rebooting, but instead of putting on a Fido 2.2 version, I put on the Roger's version.

After 40 minutes, the phone never restarted, I pushed the power button and now when it starts, it just shows some red colors and does not start.

I even followed the procedures for a clean boot (hard reset) and it still doesn't restart without those funny colours and then nothing.

Help please.
rockstead is offline  
Reply With Quote