Thread: Support Curtis Klu LT7033
View Single Post
Old January 27th, 2013, 10:43 PM   #1 (permalink)
poptart87
New Member
Thread Author (OP)
 
Join Date: Jan 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Curtis Klu LT7033

Hello. I have the tablet by Curtis, the Klu LT7033 and I have some questions about it. First and foremost, why won't it charge? I have used the charger for about 3 months and it worked fine. Now, it won't charge. Ill plug it in and it won't charge, like it normally should. If I sit there and wiggle it for 10 minutes, it might start to charge if I leave it in that exact position, without moving it. What can I do? Id really like to use it. Another question, why it won't charge via USB? like most android devices it should charge by usb. But it doesn't. It reckognizes I have it plugged in but it doesn't charge. So what can I do? I've tried resetting it, using different computers and power outlets, but no luck. Any help would be greatly appreciated. Also, sorry if this is in the wrong section.
poptart87 is offline  
Reply With Quote