View Single Post
Old February 28th, 2013, 01:59 PM   #421 (permalink)
MoodyBlues
- Crazy peacock person -
Thread Author (OP)
 
MoodyBlues's Avatar
 
Join Date: Jan 2011
Location: /home/LosAngeles
Posts: 3,278
 
Device(s): Kindle Fire HD 8.9" (rooted), Motorola Atrix 2, Motorola Atrix 4G (retired), Motorola Bravo (retired
Carrier: AT&T

Thanks: 1,077
Thanked 1,540 Times in 946 Posts
Default

Quote:
Originally Posted by palmtree5 View Post
So, in the process of migrating my linux install to a VM, the permissions changed. Quite simply, I can't log into the system in question other than booting the vm from the iso image and chrooting after mounting the partitions.
I really can't help much because I've never run Linux in a VM. So I'll leave that aspect to someone else.

Quote:
ls -l shows all of the directories at / (except /dev /lost+found /proc and /sys) having rwxrwxrwx (777) which I assume is the problem.

lost+found has 700
the other three exceptions have 755
Here's my / on the Kubuntu laptop I'm typing this on:

Code:
drwxr-xr-x   2 root root  4096 2012-11-06 19:52 bin
drwxr-xr-x   3 root root  4096 2012-11-06 19:57 boot
drwxr-xr-x   3 root root  4096 2011-10-07 07:55 build
drwxr-xr-x   2 root root  4096 2011-09-15 19:45 cdrom
-rw-r--r--   1 root root     0 2011-09-19 13:29 computer_HPdv7
drwxrwxrwx   9 root root  4096 2013-02-08 12:12 data
drwxr-xr-x  20 root root  4360 2013-02-27 16:58 dev
drwxr-xr-x 197 root root 12288 2013-02-27 10:40 etc
drwxr-xr-x   9 root root  4096 2012-10-19 19:30 home
lrwxrwxrwx   1 root root    37 2012-11-06 19:57 initrd.img -> boot/initrd.img-2.6.38-16-generic-pae
lrwxrwxrwx   1 root root    37 2011-12-04 21:32 initrd.img.old -> boot/initrd.img-2.6.38-13-generic-pae
drwxr-xr-x  20 root root  4096 2012-11-06 19:55 lib
drwx------   2 root root 16384 2011-09-15 19:36 lost+found
drwxr-xr-x   2 root root  4096 2013-02-05 22:34 media
drwxr-xr-x   6 root root  4096 2011-11-03 23:44 mnt
drwxr-xr-x   4 root root  4096 2013-01-05 14:01 opt
dr-xr-xr-x 185 root root     0 2013-02-27 10:31 proc
drwx------  38 root root  4096 2013-02-07 14:34 root
drwxr-xr-x   2 root root  4096 2012-11-06 19:52 sbin
drwxr-xr-x   2 root root  4096 2011-03-21 01:26 selinux
drwxr-xr-x   3 root root  4096 2011-09-18 00:41 srv
drwxr-xr-x  13 root root     0 2013-02-27 10:31 sys
drwxrwxrwt  17 root root  4096 2013-02-28 11:44 tmp
drwxr-xr-x  12 root root  4096 2011-09-17 15:36 usr
drwxr-xr-x  17 root root  4096 2012-10-19 19:30 var
lrwxrwxrwx   1 root root    34 2012-11-06 19:57 vmlinuz -> boot/vmlinuz-2.6.38-16-generic-pae
lrwxrwxrwx   1 root root    34 2011-12-04 21:32 vmlinuz.old -> boot/vmlinuz-2.6.38-13-generic-pae
As you can see, nothing's 777 except /data (which is a partition I always install, and want to have set to 777) and /tmp. My /proc is 555, while yours is 755; my /dev and /sys are 755 like yours; my /lost+found is 700 like yours.

Perhaps adjusting your permissions to match mine will help...or not. Like I said, I have absolutely no experience with running Linux in a VM.
__________________


MoodyBlues is online now  
Reply With Quote