View Single Post
Old April 10th, 2013, 10:48 PM   #501 (permalink)
AF Contributor
nickdalzell's Avatar
Join Date: Jun 2011
Location: Owensboro, KY
Posts: 4,019
Device(s): Nexus 10, Nexus 7, Galaxy S3, Galaxy Tab 3's
Carrier: Verizon

Thanks: 96
Thanked 631 Times in 504 Posts

for some reason while playing a game (rigs of rods) my machine acted like the filesystem was mounted read-only. game saves wouldn't work. so i exited out and tried to see what was wrong. the machine froze. i held power until it turned off. then rebooted. now i was getting this warning that 'Ubuntu is in low-graphics mode' but nothing would give feedback as there was no mouse and the keyboard wouldn't select options. i could go into alt-F1 and login, type 'startx' and it would work, but only in Unity, not KDE, and lightDM was not working. worse yet, my graphics card was now being reported back to me as 'gallium llvmpipe' instead of 'radeon hd graphics'. i didn't know what had happened. i tried all i could (again, hours of googling) and all i ended up with was an unrecoverably corrupted X install. as i said put me in front of a Linux box and it's going to be dead. it's only a matter of time. i didn't edit anything either this time, i just was using it as i had been for a long time. it had always given me hell with fsck on boot, presumably due to a problem with my chosen filesystem type that must have not played nicely with my hard drive (kubuntu works fine, in contrast) or a corrupted ISO install (but would always work fine when i finally did get X up. i could play FSX, Star Trek Online, and any other game. of course, OMSI bus sim which i was interested in didn't work at all. it is rated 'garbage' in WineHQ and doesn't work in Virtualbox. it just crashes and displays German for 'Divide by Zero'). either way it was not possible to recover it, as first of all i did not even know why it was in low-graphics mode in the first place, nor do i have any means to find out which driver it was using. it was just generically, 'radeon hd graphics'. for a time, it would work just fine if i startx as root, but would not work in my normal user account unless it was in low graphics mode. sadly, none of my games would work under my root account, even if i pointed Wine to use that prefix. it would just crash. tried copying my user's home/.wine folder to root's home/root/.wine folder and tried again pointing Wine to that prefix, still crashed. i suppose it was only possible to run those games under my user account, not root. which meant i was at a dead-end as i could not for the life of me fix my graphics problem. i then tried to disable lightdm as i do prefer a console login anyway, but all that does now is tell me that X couldn't start as there is some fatal error.

I wish there was a method to go into XF86config or some sort of means to do the same autoprobing for hardware that the installer does when you first install the system, but i could not find any such app to do that job. also, Ubuntu seems to have done away with console config of X these days, making the problem even harder to fix.

Moody, if the app/game you want to use isn't in Synaptic or any other repo, you will end up doing things the hard way. and often spend hours trying to make it work in the distro you use. perhaps you can live without certain apps or consider it a worthy trade off. but it's a deal breaker when i can't play games others can just because i'm not running Windows. it always feels like i'm imprisoned in Android or Linux, as the things i want to do i cannot do. and for me, that 'freedom' feels like a cage when you have to accept that this app or this game isn't going to work and either play a watered down copy port of it or worse, 'get used to it'. that's just not acceptable. for now i got XP working for those programs. like it or not, i'm not giving them up.
"If you treat your system like a kiln, don't be surprised when a brick comes out the other side."
nickdalzell is offline  
Last edited by nickdalzell; April 10th, 2013 at 10:52 PM.
Reply With Quote