Thread: Support Wi-Fi issue
View Single Post
Old May 9th, 2013, 01:21 AM   #39 (permalink)
peacesong
New Member
 
Join Date: May 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default S4 - Won't connect to Wifi unless security disabled, or WEP

Hi,

Got the Galaxy S4 with ATT service.

It connects and stays connected to
*) unsecured wifi
*) WEP enabled security

Tried every combination of WPA, WPA2, or WPA mixed mode using TKIP or AES and none of them work.

The phone gets stuck in a cycle of "Obtaining IP Address", "Saved, Secured"...
Sometimes it reads "Authenticating", "Saved, Secured"...
while Scanning/Connecting... it never connects.

Tried the other post suggestions of turning off the wifi power save mode (*#0011#), DHCP and static...

Note - if the password is entered incorrectly, there's an immediate failure and prompt to enter a new password.

Since it works fine with no security and WEP, i'd guess this is a software issue?

Any suggestions? Hard to believe this product could actually ship without being able to connect to the most common wifi.

Thank you for your help!

Peace
peacesong is offline  
Reply With Quote