Thread: Support Wi-Fi issue
View Single Post
Old May 9th, 2013, 08:49 AM   #40 (permalink)
NullReference
New Member
 
Join Date: May 2013
Posts: 1
 
Device(s): Samsung Galaxy S4
Carrier: Bell Canada

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Throwing my hat into the ring here, my first post so I hope I'm doing this right...

My Samsung S4 is also having wifi issues. It often will show a strong wifi connection but will have no data transfer (web pages won't load, etc...). Disconnecting from wifi and reconnecting always fixes the problem for a short period of time (from a few minutes to several hours).

There are 2 wireless routers in the house, one is a DLink DIR-655 and the other is one provided by my ISP (Bell; sorry, not sure of the model or if it matters). We also have 2 S4 phones in the house, so I'm able to troubleshoot a bit more than others. The DIR-655 is troublesome for BOTH S4 devices; they stay connected for a few minutes (or longer in some cases) but will always end up not transferring data even though they show as having a very strong signal. I read that there are compatibility issues with DIR-655 routers and the S4 devices, so I switched both S4's over to using the Bell router. Now only one of the devices (mine!) has the wifi issue described above; after being connected for a while, it just stops transferring data (switching the router to 802.11n ONLY reduced the frequency of this happening). The same thing happens to my S4 when I'm on wifi at work.

Both S4's have the most up-to-date firmware as do all of the routers in the house. No other devices (iPhones, laptops, apple tv, etc...) have any issues with the wifi.

I've tried resetting the routers, forgetting the wifi connection and setting it back up, rebooting the phone, smashing my head against the wall; nothing seems to have worked permanently.

Is it possible that this is a hardware issue and not a software issue? Does anyone know if Samsung is aware of this issue?
NullReference is offline  
Reply With Quote