View Single Post
Old May 15th, 2013, 12:16 AM   #1 (permalink)
dandiele
Junior Member
Thread Author (OP)
 
Join Date: May 2013
Posts: 26
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 6 Times in 6 Posts
Default Having an issue fastboot flashing stock recovery

Hey everyone, I am having an issue flashing my stock recovery to my t-mobile HTC one. I had my phone unlocked and rooted with TWRP recovery installed. I am wanting to go back to stock to exchange my phone for a different device altogether (long story) however, I have been able to apply my nandroid, but when i did my nandroid I dont have the stock recovery in the nandroid since I had TWRP installed.....anyway I tried to apply a stock recovery from a tmobile nandroid I downloaded, (cant post the link yet) and I was able to fastboot flash recovery recovery.img and it went fine, so in the same command prompt I did the fastboot oem lock and relocked my bootloader, however everytime I tried to reboot the phone into stock recovery it would not work. It would just flash the HTC logo, say at the top in purple booting recovery and at the bottom the RED warning and then go right back to the bootloader screen.

So i decided I would unlock the bootloader again and that worked perfectly, chose to reboot into recovery and what do you know it boots up TWRP.....

My question is how in the world do I get the stock recovery back on, relock the bootloader and do a factory reset. I understand it will say relocked at the top but the process above had it saying Tampered, Relocked, and security warning. Since I am not returning this phone for warranty, only for exchange within the buyers remorse time frame I am going to send this phone in and if Tmobile gives me grief I will send in my wifes phone instead, but she doesnt want a rooted phone etc so I want to send in mine first. I was told as long as no physical damage it didnt matter but i want to bring it to stock anyway.

Thanks in advance for any help you kind folks can provide!!
dandiele is offline  
Last edited by dandiele; May 15th, 2013 at 12:44 AM. Reason: noticed I said unlock and not relock in third paragraph
Reply With Quote