View Single Post
Old May 31st, 2013, 02:01 PM   #1 (permalink)
vacaloca
Junior Member
Thread Author (OP)
 
Join Date: Apr 2010
Location: NH
Posts: 42
 
Device(s): Samsung Galaxy S4
Carrier: Verizon Wireless

Thanks: 11
Thanked 24 Times in 5 Posts
Default [HOWTO] Enable Hidden Menus for Verizon Galaxy S4

I posted this over on XDA, but figured I'd put it here as well:

Since VZW and Samsung Level 2 support didn't know the answer, here is how to enable the hidden menus on the dialer screen for the Verizon GS4. Previously, there was a 'master' code that enabled the hidden menus. Now it is a filesystem based check. Boo!
Due to editing /system/build.prop and /efs/carrier/HiddenMenu you MUST be rooted.

1) Add the following line* to /system/build.prop
Code:
sys.hiddenmenu.enable=1
2) Change the contents of /efs/carrier/HiddenMenu from OFF to ON
3) Reboot.
4) Try it out! Go to the phone dialer and enter *#06# (show MEID) as a test.

For more codes that worked on the S3 that (should) also work on the S4, see below:
Secret to Unlocking Jelly Bean Service Modes Found

Having the hidden menus enabled is particularly useful for those who want to disable WiFi Power Saving mode -- I was having issues with an access point at work, but sadly disabling it didn't fix the problem. Otherwise, the hidden menus are useful to test your sensors/display/etc or just looking around in general. Enjoy!

For those that are NOT rooted, there is an alternative to get to SOME of these menus, but it is not a free app (currently $1.99). It's called "Samsung Sevice Mode." Note that I am not affiliated with the developer, I just bought it to test if the menus were present before I dug deeper into finding out how to fully enable the hidden menus on my Verizon Galaxy S4. When I have time in the next day or so, I'll try to figure out how the app calls the menus, and update the post if I find a free solution for those that are not rooted.

---

* Note: I added the "sys.hiddenmenu.enable=1" line right after the "persist.cne.feature=0" one, but I don't think it matters where you add it. Just be careful editing this file. I managed to get my phone boot-looping, probably because I used notepad to edit the file and it added Windows CR/LFs to it, and had to use the NoWipe Factory Image posted here to restore my phone. The second time around I used Root Explorer's built in text editor and it worked fine.

In case anyone is curious how I figured this out, click here.
vacaloca is offline  
Last edited by vacaloca; June 5th, 2013 at 07:05 PM.
Reply With Quote
The Following User Says Thank You to vacaloca For This Useful Post:
TALONTRAX (July 11th, 2013)