View Single Post
Old July 1st, 2013, 07:05 PM   #12 (permalink)
elnbryant
New Member
Thread Author (OP)
 
Join Date: Jun 2013
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

Ok, after lots of trial and error, I think we have the problem solved, though still unsure of why it happened. TMobile graciously sent me out a new battery (although they told me they weren't supposed to as the battery is not covered under the warranty). Took about 10 days...by that time, I had decided to go ahead and use the car charger, which worked great! So when I got the new battery, I installed it and tried used the original charger again. Same thing...drained the battery. So I called TMobile back and they said they would send me a new adapter to see if it would help charge the phone. Took another week and the same thing happened...drained the battery instead of charging it....I went into a TMobile store and they were able to charge the phone using their charger, so we figured out it must be the USB cord that was the problem, not the adapter or battery. It took tons of time and effort, but I appreciated Tmobile sticking with me since I was told it wasn't covered under the warranty. After all, I had just purchased a $600+ phone from them in the last 40 days. Wonder if anyone else had this problem or just my phone?
elnbryant is offline  
Reply With Quote