View Single Post
Old August 10th, 2013, 05:49 PM   #16 (permalink)
Beards
Senior Member
 
Beards's Avatar
 
Join Date: May 2010
Location: Chesterfield UK
Posts: 1,021
 
Device(s): Current: SGS4, SGS3, SGN 10.1, iPad4 64GB. Retired: SGN, SGS2, SGS, SGT7", Asus TF201, TF1
Carrier: Not Provided

Thanks: 43
Thanked 367 Times in 207 Posts
Default

Twister,
Help..... I am in need of your assistance please.
This morning I put the charger on charge as it had depleted most of the cells.
After 3hrs it had only lit up one further cell (2 cells in total) but I left it to carry on.
After a further 3 hours I checked it again and it still had only the two cells showing as charged.

All day and evening I have tried it with two other USB Mains chargers and none of them will charge the charger any further.
All it shows is the charging lights lighting then going out with only the first two showing as charged.

As such this device is defective.

Can you please speak with Anker about this for me. Unfortunately I am not in a position to send it back to Amazon just yet (holiday coming up) and knowing Amazon they will want me to pay postage to send it back which I am reluctant to do seeing as the item is obviously defective.

Look forward to hearing your comments.

Beards
__________________
.........I don't always get your questions right.... but you'll certainly know I've tried.
P.S. Many thanks for the Thanks votes. Thanks received are converted into a charitable donation.
Beards is offline  
Reply With Quote