View Single Post
Old August 27th, 2013, 03:45 PM   #1 (permalink)
gromit0010
New Member
Thread Author (OP)
 
Join Date: Jun 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 3 Times in 2 Posts
Default MertoPCS-->CM10.2-->Brick-->T-mob stock FW Working

Read on I bricked it and got it back. I think some of you might find this helpful as I had to learn the hard way. As of this date there are no stock recovery ROMs for the MetroPCS S4; so if you botch a flash or have to return or repair the phone you cannot go back to stock. Most may also know that the T-mob TWRP and CWM recoveries are functional on the MertoPCS S4. The first thing I did after I flashed TWRP 2.6.0.0 with Odin was make a clean non-rooted backup. I then rooted which worked at that time.

I then flashed a few T-mob roms and wanted to get back to my original MetroPCS 4.2.2 recovery. I was able to return to stock but when I attempted to root as before I was able to install SU but did not have root. Small detail, when I recovered I was prompted by TWRP to root so I did but then ended up installing root manually as I had before. So I wiped cache, flashed back to another ROM, then recovered again and rooted. Still had root but no root permissions. I should have left it be an waited for a more calculated solution.

Well, I ended up wiping just about everything possible in TWRP which was, looking back, a bad idea. I had to put my recovery back on my SD card and load up TWRP only to find that TWRP could not see the recovery directory or files on my SD card. But, if I selected the install option it was able to see my files and directories just fine. Bottom line, I was now stuck in a boot loop and TWRP was not recognizing my recovery (which I did copy over multiple times to the SD). So now I had a two day old 600 dollar brick.

Finally I decided to flash the T-mob stock ROM with Odin. Thankfully it worked and I was back to stock but on a T-mob Rom. The phone now read to be a SGH-M919 not the SGH-M919N, TWRP was removed, and the ROM showed the be official by Samsung. I tried the free GSM unlock procedure which now worked on the T-mob rom. The process did work as described but my phone is still locked. I still intend to return to MetroPCS 4.2.2 if possible but TWRP 2.6.0.0 still not seeing my recovery files in the restore option. I still have service and my phone works fine but I would like to get back to stock if possible. Any help with the TWRP issue would be welcome. Hope this helps some of you all.
gromit0010 is offline  
Reply With Quote