Thread: Support Wi-Fi issue
View Single Post
Old September 14th, 2013, 11:27 AM   #126 (permalink)
xiteg79
Junior Member
 
Join Date: May 2011
Location: South FLorida
Posts: 60
 
Device(s): Samsung Galaxy S4 Droid X (Retired) Droid Bionic (Retired) Samsung Galaxy Tab 10.1
Carrier: Verizon

Thanks: 20
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by Canesfan View Post
Now, my latest issue is that the phone is not holding its established WiFi connection and/or doesn't automatically complete a WiFi connection as it had been doing, such as with my home WiFi . None of my home or phone settings have changed.

This phone has WiFi issues !!! (I'm saying for the 1001-th time....)


Now, for all of you wanting to respond that your S4 is rock solid with WiFi, good for you!
Yup this is really pissing me off also. I have updated my firmware on my home router when there was no issues before when I first got the phone. I did a forget network on the phone and tried to add it back over and over again. The phone does a scan of wireless networks, then says that the home network is saved and secured then tries to re-establish and IP then obtains an IP then saves and secures. Then the phone scans the wireless networks and repeats the whole process over and over and over again.


So I got so pissed off while writing this that I went into my router and started messing with some settings. I have a linksys ea2700 with updated firmware. Side note, I hate this router and what linksys has done.

So, I noticed that my wireless was set for wpa/wpa2 personal mixed mode. I set it this way because my xbox will not connect to wpa2!! Since I rarely use my xbox I changed the setting for both 2ghz and 5 ghz to just wpa2 personal. And, HOLY SH** it worked!!!!!!!!!!!

I have now had a solid connection for over 15 minutes and ran speed tests with solid results. Though I still notice the device scans networks every 5 seconds still but the connection to my router is solid.

Though the problem at my work is still going to persist as they use mixed mode there as well. So it seems the problem lies in the gs4 not taking mixed mode very well. Or, at least it does not like mixed mode on the specific router that I have.

Hope this helps others
xiteg79 is offline  
Reply With Quote