View Single Post
Old October 7th, 2013, 09:58 AM   #1 (permalink)
friis99
New Member
Thread Author (OP)
 
Join Date: Oct 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default ROM flash fails - sdcard/0 does not exist

Galaxy S4, I9505 - running 4.2.2

Trying to install new ROM (Foxhound) I get this error:
-- Installing: /sdcard/0/Download/FoxHound_2.0_By_Snakes_GT-I9505.zip
Finding update package...
I:Update location: /sdcard/0/Download/FoxHound_2.0_By_Snakes_GT-I9505.zip
I:using /data/media/0 for /sdcard/0/Download/FoxHound_2.0_By_Snakes_GT-I9505.zip.
I:using /data/media/0 for /sdcard
Opening update package...
E:Can't open /sdcard/0/Download/FoxHound_2.0_By_Snakes_GT-I9505.zip
(No such file or directory)
Installation aborted.
result was NULL, message is: assert failed: install_zip("/sdcard/0/Download/FoxHound_2.0_By_Snakes_GT-I9505.zip")
I:using /data/media/0 for /sdcard.
I:using /data/media/0 for /sdcard

From terminal or file explorer, this ZIP file can be seen via :
/storage/emulated/0/Download
/data/media/0/Download
/sdcard/Download

(all the same data)

BUT /sdcard/0 does not exist


Tried all sorts of SYMLINKS and MOUNTS but nothing worked or was not allowed.

Shouldn't I have sdcard/0 linked to /data/media/0/ ??

What do I do?

PS - at one point the device did a factory reset at boot up (after first failled install including wipe of data) - then I reflashed the backup
friis99 is offline  
Reply With Quote