View Single Post
Old October 12th, 2013, 05:02 AM   #13 (permalink)
philayl
Member
 
Join Date: Jun 2010
Location: Wirral, Merseyside
Gender: Male
Posts: 250
 
Device(s): Galaxy S5 (G900F)
Carrier: Tesco Mobile

Thanks: 12
Thanked 58 Times in 41 Posts
Default

Quote:
Originally Posted by nytmare View Post
I've tried virtually everything to get my S3 to connect to my laptop and have not been successful. The funny thing is, it use to connect to my old laptop that ran Windows XP and had 2.0 USB ports (its motherboard fried a few weeks ago unfortunately). It didn't do it consistently, but after playing with it, I could eventually get it to connect as an MTP device (I never had Kies loaded on my old laptop). My new laptop is running Windows 8 and has 3.0 USB ports. I've used the most up to date driver and I've used the previous driver with no luck. I also can't get Kies to find it. It simply tries to connect, but never does. I know my laptop knows the S3 exists 'cause I can see it in my Device Manager. It even says the device is working properly. Still can get to it via Windows Explorer or Kies.

I'd like to root my phone, but can't if the laptop won't connect to it. This sucks...
Hi, I had the same problem, I used these drivers and every thing works ok now. Phil
http://www.station-drivers.com/index.php/10-drivers/40-asmedia
Download and install the top driver on the right Version 1.16.10.0
philayl is offline  
Last edited by philayl; October 12th, 2013 at 05:07 AM. Reason: Previous link not working
Reply With Quote
The Following User Says Thank You to philayl For This Useful Post:
nytmare (October 17th, 2013)