Go Back   Android Forums > Android Phones > Samsung Galaxy Ace > Ace - All Things Root

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old March 31st, 2012, 08:35 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Soft key lights keep turning on

I have CM7.2 installed and my soft key lights have a mind of their own. They turn on every few seconds and it isn't because of a notification. The only suggestion I have found is to install an app that turns off the lights. I tried a couple and they don't work. The lights still come on. I have tried reflashing and I don't think an app is causing this.

tmpearson is offline  
Last edited by tmpearson; March 31st, 2012 at 11:17 AM.
Reply With Quote
sponsored links
Old April 1st, 2012, 02:20 AM   #2 (permalink)
Member
 
Rooferkev's Avatar
 
Join Date: Nov 2010
Location: England
Gender: Male
Posts: 245
 
Device(s): Samsung Galaxy Ace and Iphone 3gs
Carrier: Not Provided

Thanks: 11
Thanked 27 Times in 23 Posts
Default

Its one of the clitches that needs to be sorted out on CM7, it should only be happening when wifi is on. It should be sorted in comming versions
Rooferkev is offline  
Reply With Quote
Old April 1st, 2012, 03:05 PM   #3 (permalink)
Member
 
PJ147's Avatar
 
Join Date: Jun 2011
Location: Hampshire, UK
Posts: 457
 
Device(s): Galaxy Note N-7000 Galaxy Ace GT-S5830
Carrier: Not Provided

Thanks: 19
Thanked 137 Times in 82 Posts
Default

It sometimes happens without wifi too. Look at the official cm thread for known faults
__________________
Galaxy Note N-7000 & Galaxy Ace

Waiting for official Note Jelly Bean and CM10 for galaxy ACE (Jellaxy)
PJ147 is offline  
Reply With Quote
Old April 2nd, 2012, 12:18 PM   #4 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by tmpearson View Post
I have CM7.2 installed and my soft key lights have a mind of their own. They turn on every few seconds and it isn't because of a notification. The only suggestion I have found is to install an app that turns off the lights. I tried a couple and they don't work. The lights still come on. I have tried reflashing and I don't think an app is causing this.
Hi. I got the same problem. Using cyanogenmod 7.2.0 RC1 cooper version on samsung galaxy ace. It's a bit annoying that the soft keys are lighting up in every 10-15 seconds. It's a bit annoying, however it doesn't consume much battery as i heard... i would really welcome some good advise how could i fix this bug.
Oh and the cam has no zoom!
fgellert is offline  
Reply With Quote
Old April 2nd, 2012, 12:47 PM   #5 (permalink)
Member
 
PJ147's Avatar
 
Join Date: Jun 2011
Location: Hampshire, UK
Posts: 457
 
Device(s): Galaxy Note N-7000 Galaxy Ace GT-S5830
Carrier: Not Provided

Thanks: 19
Thanked 137 Times in 82 Posts
Default

Its a known issue(as said above) it should get fixed as an update before a Stable release. The camera wont zoom on Max resolution. Lower the resolution or even better, take picture and then crop as you'll get a better image.
PJ147 is offline  
Reply With Quote
Old April 2nd, 2012, 01:16 PM   #6 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

i reduced the quality of camera and still no zoom Seems to be another bug
fgellert is offline  
Reply With Quote
Old April 3rd, 2012, 01:22 PM   #7 (permalink)
Member
 
PJ147's Avatar
 
Join Date: Jun 2011
Location: Hampshire, UK
Posts: 457
 
Device(s): Galaxy Note N-7000 Galaxy Ace GT-S5830
Carrier: Not Provided

Thanks: 19
Thanked 137 Times in 82 Posts
Default

we have a maintainer - Check the offical cyanagenmod 7.2 thread..........
PJ147 is offline  
Reply With Quote
Old May 13th, 2012, 02:44 PM   #8 (permalink)
Member
 
Join Date: Jan 2012
Location: UK
Posts: 229
 
Device(s): Galaxy Ace Black
Carrier: Not Provided

Thanks: 27
Thanked 20 Times in 18 Posts
Default

I not got the LED issue although the built in LED stuff on CM didnt seem to work for me anyway, I got a unofficial version of CM now which works with the proper BLN app which has no such issues.
chrcol is offline  
Last edited by chrcol; May 13th, 2012 at 03:06 PM.
Reply With Quote
Old May 13th, 2012, 04:39 PM   #9 (permalink)
Senior Member
 
Join Date: Aug 2011
Location: Delhi
Posts: 1,258
 
Device(s):
Carrier: Not Provided

Thanks: 18
Thanked 241 Times in 223 Posts
Default

I am using the old grifs version and i haven't seen the softkey lightening up on its own, atleast not during standby. While operating the handset it does come on without touching it, but not anything noticeable.
On stock sometimes the keys would just light up on their own and won't turn off even on standby, the only solution was to reboot.

Ya LED and zoom doesn't work for me too...

I think slaid480 is the CM maintainer now, i am not sure.
__________________
Device: Samsung GT-S5830 Galaxy Ace
ROM: AOKP 4.2.2
Scripts: CronMod INT2EXT4+
Kernel: 2.6.37.6-jellybean+marco@pc5 #14
CPU Frequency: 245MHz - 800MHz, SmartassH3
ayush29k is offline  
Reply With Quote
Old May 14th, 2012, 02:27 AM   #10 (permalink)
Member
 
Join Date: Jan 2012
Location: UK
Posts: 229
 
Device(s): Galaxy Ace Black
Carrier: Not Provided

Thanks: 27
Thanked 20 Times in 18 Posts
Default

I got the same issue now.

When I get a missed call BLN pro is configured to do this and worked perfect on stock rom.

Light up for 3 seconds.
Go off for 2 minutes
Light up for 3 seconds
Off for 2 minutes and repeat forever until I acknowledge it.

On CM7.2 the LED's come on for the 3 seconds, then go off but then 1 second later come back on and then stay on.

The problem is I cant find a way to contact CM rom developers, it seems no email address etc. Last rom was 3 weeks ago.

From what I can see it appears to be using the force LED's on when is setto use application setting. So is a bug. I have a growing list of niggles with CM at the moment.
chrcol is offline  
Last edited by chrcol; May 14th, 2012 at 02:30 AM.
Reply With Quote
sponsored links
Old May 14th, 2012, 02:41 PM   #11 (permalink)
Member
 
PJ147's Avatar
 
Join Date: Jun 2011
Location: Hampshire, UK
Posts: 457
 
Device(s): Galaxy Note N-7000 Galaxy Ace GT-S5830
Carrier: Not Provided

Thanks: 19
Thanked 137 Times in 82 Posts
Default

Bln is kernel dependent. Works with some and not with others. For support its best to speak to the developer of the app not cm developers. The issue reported in this thread is not bln related though, it was a bug of the earlier official nightly builds
PJ147 is offline  
Reply With Quote
Old May 15th, 2012, 12:57 AM   #12 (permalink)
Member
 
Join Date: Jan 2012
Location: UK
Posts: 229
 
Device(s): Galaxy Ace Black
Carrier: Not Provided

Thanks: 27
Thanked 20 Times in 18 Posts
Default

I have an update.

On XDA another user of BLN pointed out the problem appeared when BLN introduced the proximitiy sensor feature, prior to that BLN was 100% working with CM7.

So I uninstalled BLN pro and installed BLN free, BLN free has not been updated in a while and doesnt have any proximity sensor feature.

I did this test.

BLN pro I disabled all blinking and set to the LED just stays on for a notification. When I did a missed call or just a BLN led test the LED would mostly stay on but randomly go off for a second beforce coming back on, sometimes moving the phone triggers it but not always.

BLN free configured the same way (cant be configured another way is restricted), the LED stays on 100% as it should do. Since CM has a missed call LED feature for now I am using BLN free and accepting I cant use the blinking function, however I will only do this temporarily.

Here comes the problem as I see it.

Android developers are different to windwos developers, they seem to get offended on things like asked for ETA etc. The accepted motto on XDA is if you use software then you are expected to accept thaty the developer may stop supporting it and you cant ask for things like progress reports, eg. the last CM update was many weeks ago and it could be months before another update or it could be a day, we dont know. There is no email address to contact them and I havent seen one post on any of the CM threads on forums, this to me is not a good way to develop and communicate with your users. Instead there is the bugtracker which however makes it clear if there is no logcat or whatever its called they will reject the bug report, so there is clear barriers to reporting bugs. Which goes some way to explaining why CM is so buggy.

I have however left a post on the BLN XDA thread but its worth pointing out the BLN dev ignored the other guy who posted about CM weeks ago on it. BLN is a paid app so I do expect a reply and fix of him as I have paid for it. Whether I get one I dont know. My gut guess is its a proximity sensor issue and if the BLN dev releases the old BLN version again (before he added the sensor code) it will work fine. Ultimately its a CM bug tho.

Also to add CM7.1 has the same issue as well, I thought it didnt at first but it does. Plus it behaves better when the usb is plugged in for some reason.
chrcol is offline  
Last edited by chrcol; May 15th, 2012 at 01:13 AM.
Reply With Quote
Reply
Tags
ace, cm7, key, lights, soft


Go Back   Android Forums > Android Phones > Samsung Galaxy Ace > Ace - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:20 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.