Go Back   Android Forums > Android Discussion > Android Applications
Android Applications All the information you could ever want about Android Applications. Learn about apps and get help with them... all here! New apps can be found and announced in the Applications Announcements forum linked below.

test: Reply
 
LinkBack Thread Tools
Old November 13th, 2010, 08:34 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2010
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Exchange Activesync problem Desire HD: Cannot send from Android native mail app

So I have a brand new Desire HD. Up until 2 days ago, everything was working perfectly with my Outlook Exchange Account on the native Android Mail application. Running Android 2.2

Since then, there is something wrong with our Outlook certificate, and when I launch Outlook on my PC, I get a message that the name on the certificate is not valid. Ok, fine. So on the PC, I press "OK" and I am off and running.

On the Desire, I still get email, but if I try to SEND and email, it neither reaches the recipient, nor does the email end up in the "Sent" mail folder. When I go to "Accounts and Sync" and look at the Exchange account, I also see that i have a sync protocol error on Contacts syncing.

Now, I have installed Touchdown, and I CAN send email from here. Also, I have a friend who has an older Android phone that does not seem to be affected in a similar fashion connecting to the same exchange server.

Problem: The Touchdown app is kind of a pain from a user interface standpoint when you try to edit a contact. and it costs $20. And, I really prefer the native Mail widgets and stuff.

I am stuck using Touchdown at the moment so that I can send and receive emails, but I am hoping to find a workaround. Our IT people are working on the certificate problem, so maybe that will help. HOWEVER, I cannot afford to be without email every time there is a certificate problem.

I have searched for literally hours looking for a solution to this, but cannot find one that matches this problem.

Any help would be appreciated.

THanks,

Wes

Advertisements
wesramm is offline  
Reply With Quote
sponsored links
Old November 24th, 2010, 08:38 PM   #2 (permalink)
New Member
 
Join Date: Nov 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Did you get an answer?

Hey wesramm did you get an answer to this issue - I've got exactly the same issue myself, with an HTC Desire HD on Froyo 2.2
sirtwist is offline  
Reply With Quote
Old December 22nd, 2010, 01:16 AM   #3 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 1
 
Device(s): Desire Z
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm curious as to whether you got an answer as well, am having the same problem with my Desire Z.
Biek is offline  
Reply With Quote
Old December 29th, 2010, 01:44 PM   #4 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 1 Post
Default

Similar problem here.

Odd thing is that it works fine when I'm on wifi. Both sending and receiving mail is fine then.

When I switch to data connection (via phoneline) then receiving still works, but cannot send anymore any e-mail.

Tried using K-9 instead - exactly same behaviour.


HTC Desire HD on Android 2.2
*********
tools4fools is offline  
Reply With Quote
Old February 22nd, 2011, 02:41 PM   #5 (permalink)
New Member
 
Join Date: Feb 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Same here on a Telus Fascinate

I'm having the exact same issue here on a Telus Fascinate (which is actually a rebranded Vibrant). Everything was working for a couple of weeks, and now everything except sending mail works.

Anyone find a workaround?
kmacl is offline  
Reply With Quote
Old February 23rd, 2011, 10:33 AM   #6 (permalink)
New Member
 
Join Date: Feb 2011
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same issue with the native mail app on my HTC dhd. Download of mails from our Exchange server is working, but when I send a reply or compose new mail, it doesnt go out.

Anyone have any ideas on how to fix this?

I also get the certificate notification but just press accept/ continue.
mamyel is offline  
Reply With Quote
Old April 7th, 2011, 07:11 AM   #7 (permalink)
New Member
 
Join Date: Apr 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Send mail on Activesync not working

I think I'm in the same boat with my HTC Desire HD.

Got the phone 10 days ago, all worked fine. Then 2 days ago, sending stopped working for my work address on the native app (Exchange ActiveSync).

I have a Gmail (IMAP) and a Yahoo (POP) account also through the native mail app and they receive and send fine. My work email (Exchange ActiveSync) receives but does not send.

I have deleted and re-loaded my ActiveSync account, but still nothing. I've even deleted both my Gmail and Yahoo accounts from the native app and used the downloadable apps for each of those (and they still work).

I'm in Australia on the Optus network.

Could this be an HTC issue?

Cheers.
Aj07 is offline  
Reply With Quote
Old May 5th, 2011, 01:38 AM   #8 (permalink)
New Member
 
Join Date: May 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Can't send emails from my HTC Desire

Hi,
I can't send (or reply to) emails on my Exchange account. Gmail works fine, but I can't send using my work account which is Exchange. Anybody know a work around ? Touchdown doesn't seem to work either. I can read emails, but can't reply... very frustrating.

Was on the phone to HTC for over an hour to no avail. Wish I had bought an iphone...?!
arathi is offline  
Reply With Quote
Old May 16th, 2011, 06:39 PM   #9 (permalink)
New Member
 
Join Date: May 2011
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Can't e-mail out from HTC Desire HD on ActiveSync Acc

Same issue here. receive work e-mails but can't e-mail out: message appears in outbox, then disappear on next sync cycle, can't be found in Outbox nor syncIssues ...

Cheers
Tolosyv is offline  
Reply With Quote
Old May 16th, 2011, 11:25 PM   #10 (permalink)
New Member
 
Join Date: Feb 2011
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the same issue and posted in Feb-11 about my exchange problem. the only solution i found was to use Moxier Mail to get my mails.

After fiddling around, just randomly i tried launching the HTC mail app recently, and for some reason its working now! I cannot find what changes were made, as i did not do any update nor re-format my phone.

I just remember registering my account again under "Settings\Accounts & Sync" because i had sync problems with my Contacts, and then the mail worked. Sending and recieving is ok.

Now im kinda worried that if something happens and I do need to factory-reset my phone, that the mail will not work again

FYI, Im still on 2.2.1, SW#: 1.84.707.2 using an unbranded DHD.
mamyel is offline  
Reply With Quote
sponsored links
Old May 16th, 2011, 11:31 PM   #11 (permalink)
Junior Member
 
Join Date: Apr 2011
Location: New Zealand
Posts: 75
 
Device(s): HTC Desire running Cyanogenmod7 (7.1.0) Build GWK74
Carrier: Not Provided

Thanks: 15
Thanked 6 Times in 6 Posts
Default

Quote:
Originally Posted by Tolosyv View Post
Same issue here. receive work e-mails but can't e-mail out: message appears in outbox, then disappear on next sync cycle, can't be found in Outbox nor syncIssues ...

Cheers

Are you running Juice Defender or any similar app. These can play havoc with Exchange sync.
muzzman is offline  
Reply With Quote
Old May 24th, 2011, 09:13 PM   #12 (permalink)
New Member
 
Join Date: Apr 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Reason why ActiveSync won't work

HTC replied to my ticket. Android 2.2 does not fully support Exchange 2010 (which now explains why I can receive but not send email). There is an upgrade to Android 2.3 which has begun to be rolled out (they said by June 2011), but they couldn't tell me exactly when my mobile carrier would implement the upgrade. So now I'm waiting...

So if your email client uses Exchange 2010, chances are you need to wait for the 2.3 upgrade too...
Aj07 is offline  
Reply With Quote
Old June 4th, 2011, 12:49 AM   #13 (permalink)
New Member
 
Join Date: May 2011
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just installed 2.3 upgrade and problem fixed ...
- Temporary solution before that was to run 30 days free trial version of Touchdown
- Worked perfectly but kinda ugly to my taste
- Need to reset phone to manufacturer specs every 30 days to reset trial.
Tolosyv is offline  
Reply With Quote
Reply
Tags
exchange active sync, sync protocol error


Go Back   Android Forums > Android Discussion > Android Applications
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:13 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.