Go Back   Android Forums > Android Discussion > Android Applications
Android Applications All the information you could ever want about Android Applications. Learn about apps and get help with them... all here! New apps can be found and announced in the Applications Announcements forum linked below.

New Forums: Nexus Player | Nexus 9
test: Reply
 
LinkBack Thread Tools
Old January 6th, 2012, 08:18 AM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 40
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 4 Times in 4 Posts
Default *resolved* Sync errors when setting up gmail as an exchange account

Evo 4g
Mik3g Rom
Android 2.3.3
Sense 2.1

Hello all, I am a long time K9 mail user who recently flashed a new rom and was too lazy to reinstall k9, so i figured i'd just use the stock HTC mail and gmail apps until they motivated me to sit down and set up K9. To my surprise both Apps have come a LONG way since I first got my android phone. The gmail app is my favourite but since I need to have my work account on my phone and I don't really like having two mail apps I switched over to the stock HTC mail app which is getting close to perfect - especially since I learned you can set up gmail as an exchange account. The problem is it is extremely unreliable at best.

Here is how i set it up:
mail
new account
exchange
username@gmail.com
password

server = m.google.com
domain = google

It works for a while but eventually I get a sync error. if i go into settings and, without changing anything, press save a few times eventually it reconnects. on a reboot it connects. everything is fine but eventually it stops working until i manually go in and fiddle with it. obviously this is suboptimal.

I am using Green Power Premium which shuts off all of my radios when i am not hooked into power and then periodically turns them back on long enough for sycn/push. Naturally I suspected this to be the culprit so I turned it off but i had the same problem. i even went so far as uninstalling it but that didn't help.

Am I doing something wrong or is this just a feature that is still a work in progress?

If I can get this to work and if they can fix embedded images not showing up properly in mail and 1 or 2 other minor quirks then the stock mail app will be the best app for my needs.

As it were gmail on k9 with push enabled works fine - i just don't like the way it looks nor the lack of threaded conversations, the latter being a deal breaker for me.

thanks all!

Advertisements
Displacedmic is offline  
Last edited by Displacedmic; January 10th, 2012 at 11:54 AM.
Reply With Quote
sponsored links
Old January 10th, 2012, 11:55 AM   #2 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 40
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 4 Times in 4 Posts
Default

Hi guys - i wanted to post a followup that thanks to some serious digging into old threads i just stumbled upon the resolution to this problem - and right as i was giving up too

solution: turn off wifi when you set up your exchange account.

i have no idea why this fixes it but it does.

Setting up Gmail as an exchange address


turn wifi radio off
open mail
menu > more > new account
microsoft exchange activesync
email address: username@gmail.com
password
manual setup

Email : username@gmail.com
server address: m.google.com
domain: google
username: username@gmail.com
password
check this server requires an encrypted ssl connection
sync what you want, when you want, click next
rejoice
Displacedmic is offline  
Reply With Quote
Old November 29th, 2012, 01:32 PM   #3 (permalink)
New Member
 
Join Date: Nov 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Red face Samsung galaxy s3

I tried following the directions that were listed for manual set up and continued to receive message that says that unable to connect to server.

The domain/user name are on the same line separated by a forward slash.

Entering my password and using the advised server address. Selected to use secure connection SSL.

What am I missing?

Any help will be greatly appreciated.
yankeentx is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Discussion > Android Applications
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:27 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.