Go Back   Android Forums > Android Discussion > Android Applications
Android Applications All the information you could ever want about Android Applications. Learn about apps and get help with them... all here! New apps can be found and announced in the Applications Announcements forum linked below.

New Forums: Nexus Player | Nexus 9
test: Reply
 
LinkBack Thread Tools
Old February 11th, 2012, 08:05 AM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jan 2012
Posts: 53
 
Device(s):
Carrier: Not Provided

Thanks: 39
Thanked 10 Times in 10 Posts
Default S2E with Link2SD make new apps don't work until reboot

I have Wildfire S rooted with CM7, and I installed S2E to move dalvik cache to sd-ext, then I installed Link2SD to have more control on which apps to be moved.
After installing Link2SD s2e doesn't have control on any thing but dalvik cache (I think because Link2SD took control over the ext partition)
Any way, now when I install a new app , it doesn't open (gives force close message) untilled I reboot my device.
So is there a way to fix this problem ?
Thanks.

Advertisements
moustafaatchy is offline  
Reply With Quote
sponsored links
Old February 11th, 2012, 08:34 AM   #2 (permalink)
Senior Member
 
wyelkins's Avatar
 
Join Date: Jun 2011
Location: Savannah, GA
Gender: Male
Posts: 1,283
 
Device(s): Samsung Galaxy S3. Android 4.1.2 Samsung Galaxy Prevail, 2.3.7, FF19, Hroark CM 7.1 Bet
Carrier: Boost

Thanks: 1,134
Thanked 383 Times in 276 Posts
Default

Quote:
Originally Posted by moustafaatchy View Post
I have Wildfire S rooted with CM7, and I installed S2E to move dalvik cache to sd-ext, then I installed Link2SD to have more control on which apps to be moved.
After installing Link2SD s2e doesn't have control on any thing but dalvik cache (I think because Link2SD took control over the ext partition)
Any way, now when I install a new app , it doesn't open (gives force close message) untilled I reboot my device.
So is there a way to fix this problem ?
Thanks.
Others will have other opinions, but I would either:

Use S2E by itself
Use A2SD by itself
wyelkins is offline  
Reply With Quote
The Following User Says Thank You to wyelkins For This Useful Post:
moustafaatchy (February 11th, 2012)
Old February 11th, 2012, 08:39 AM   #3 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jan 2012
Posts: 53
 
Device(s):
Carrier: Not Provided

Thanks: 39
Thanked 10 Times in 10 Posts
Default

I want to use Link2Sd to choose which apps to be moved, s2e moves all apps
don't know about A2Sd, does it move dalvik cache and let me choose apps?
moustafaatchy is offline  
Reply With Quote
Old February 11th, 2012, 11:12 AM   #4 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jan 2012
Posts: 53
 
Device(s):
Carrier: Not Provided

Thanks: 39
Thanked 10 Times in 10 Posts
Default

It's solved now
I followed this guide, but skipped unwanted steps
14. From root explorer:
a) Navigate to /sdcard/cm7-a2ext/link2sd-config-scripts/ use multi-select on 11link2sd and 99complete then select Copy.
Navigate to /etc/init.d/ and select mount r/w from the upper right corner of the screen.
c) Paste the copied files.
15. Long press 11link2sd and select Permissions. Ensure that the permissions are set to rwxr-x---. Repeat this step for 99complete.
16. Reboot phone.
17. From the market install Link2sd and S2E.
18. [Optional] Open S2E and enable the dalvik cache and download cache options. Moving applications are not necessary. (you must enable 'Mount as ext4' before reboot)
19. Open Link2sd (if you are prompted to select a partition type, see the link2sd note below. otherwise you should have working a2ext).
20. Reboot to complete the S2E changes.
21. Congratulations! You should now have a2ext with cm7

[MOD][HOW TO] apps2ext for cm7 [updated 03/31/2011] - CyanogenMod Forum
moustafaatchy is offline  
Reply With Quote
Old February 12th, 2012, 12:05 PM   #5 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jan 2012
Posts: 53
 
Device(s):
Carrier: Not Provided

Thanks: 39
Thanked 10 Times in 10 Posts
Default

The problem is still there
After installing a few apps and restoring apps with Titanium Backup it's there again.
moustafaatchy is offline  
Reply With Quote
Old February 19th, 2012, 12:27 PM   #6 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jan 2012
Posts: 53
 
Device(s):
Carrier: Not Provided

Thanks: 39
Thanked 10 Times in 10 Posts
Default

I knew where the problem was and solved it.
I used Link2SD with linking dalvik cache files which were moved by S2E
So I edited Link2SD options not to link dalvik cache
But S2E stops working after installing Link2SD
So I moved the dalvik cache using this guide, then installed Link2SD which worked fine
A2SD Darktremor for CM7 on Samsung GT-S5570 - Cool Android Gadget
moustafaatchy is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Discussion > Android Applications
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:18 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.