Go Back   Android Forums > Android Discussion > Android Lounge
Android Lounge A place for general Android discussion and questions.

View Poll Results: If you are having the Policies page issue, what model phone?
HTC Desire HD 1 7.69%
HTC Desire - Other 4 30.77%
HTC - Other 1 7.69%
LG 0 0%
Motorola 0 0%
Samsung 3 23.08%
Sony 0 0%
Google Galaxy Nexus 0 0%
Google - Other 0 0%
Acer 0 0%
Dell 0 0%
Other 0 0%
Not having this issue 4 30.77%
Multiple Choice Poll. Voters: 13. You may not vote on this poll

test: Reply
 
LinkBack Thread Tools
Old March 9th, 2012, 07:49 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Confused Google Play App Problems. Cannot access Google Play or Market. Stuck on Policies page

Summary: Problems with Google Play, can only see a Market App, and no Google play. Market app misbehaves as shown below.

I can see a Market app but no Google Play app, searching through the entire installed apps list. Loading the market app results in a policies page for Google Play being shown, and nothing else, no Accept or Decline buttons to continue further. See below for detailed explanation of the problem.

I have a HTC Desire HD
Android 2.3.5
Market App Version: 2.3.6 (From Manage Apps)

Steps to recreate:
1) Turn on phone.
2) Press Home button to show home screen
3) Press Menu, then All Apps.
4) Click on Market.

Expected results user should see ( i am guessing here, as it hasnt worked for me):
Market App loads, and then should display some sort of welcome to Google Play, and shows Accept and Decline buttonts to Google Play terms and conditions.

Actual Results that the user sees
Market app loads, and very briefly shows a screen with "Loading..." and two buttons, "Accept" and "Decline."
HOWEVER, This screen then disappears in a split second, when a browser window is loaded, showing the "Google Play Business and Program Policies."

Scrolling through the page, there is no link or button to Accept or Decline the terms or go anywhere else. The only links at the bottom are the page footer links including Google copyright, Privacy and Terms, and Help.

Resolutions steps attempted
HTC and the help on the Web suggested the following, with no luck.
- Restart the phone.
- Restart the phone by pulling out the battery while phone is on. Wait 12 seconds, then replace battery and start phone.
- Go to manage applications, and Clear Cache and Clear Data.
- Reset phone to factory settings.
- Reset phone to factory settings, and setup Google account, then try Market app again. Stil same problem.
- Reset phone to factory settings, and SKIP Google account login/linking to phone. Clicking on Market now asks to login to Google but still loads the web page with the terms and no accept/decline button.
- THEN (getting more frustrated, can you tell?) I reset phone to factory settings, logged in with another Google Acccount (as i thought maybe a settings flag has been corrupted in my account, causing Market/Play not to work. STILL no luck, and results in same problem.

I have emailed Google, will see what happens with that, I have scoured the web and Google Help for anyone else having these problems, but could not find anything, apart from some issues with Motorola I which seem unrelated.

I called Vodafone, who tried their best to help, but it seems to be more a Google problem. They did however find this forum post, which is great, as its the first one ive seen that shows that someone else is having this issue, and that its not something specific to me.

Is there anywhere I can post this defect report officially?

Advertisements
redfox05 is offline  
Last edited by redfox05; March 9th, 2012 at 08:41 AM. Reason: Improving formatting in the post for readability
Reply With Quote
The Following User Says Thank You to redfox05 For This Useful Post:
Googleplaycrap (March 9th, 2012)
sponsored links
Old March 9th, 2012, 08:27 AM   #2 (permalink)
Fixing stuff is not easy
 
Join Date: May 2011
Location: Over there <points>
Gender: Male
Posts: 7,690
 
Device(s): Samsung Galaxy S3; Asus Infinity
Carrier: Sprint

Thanks: 2,117
Thanked 4,314 Times in 2,513 Posts
jerofld
Default

Have you tried clearing data/cache on the new market? Settings > Applications > Manage Applications > All tab > Play Store > Clear data.
jerofld is offline  
Reply With Quote
Old March 9th, 2012, 08:35 AM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

The new Market (Google Play) does not show up. You can only see the old one, which results in the behaviour show above, for which i have tried the clear data/cache. Still no luck.
redfox05 is offline  
Reply With Quote
Old March 9th, 2012, 08:58 AM   #4 (permalink)
Fixing stuff is not easy
 
Join Date: May 2011
Location: Over there <points>
Gender: Male
Posts: 7,690
 
Device(s): Samsung Galaxy S3; Asus Infinity
Carrier: Sprint

Thanks: 2,117
Thanked 4,314 Times in 2,513 Posts
jerofld
Default

I had this problem with my tablet. I think I had to reboot it a few times to get the new market to take over. It was a pain, regardless. If you use the web market (play.google.com) it'll still work for your phone.
jerofld is offline  
Reply With Quote
Old March 9th, 2012, 09:14 AM   #5 (permalink)
New Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by jerofld View Post
I had this problem with my tablet. I think I had to reboot it a few times to get the new market to take over. It was a pain, regardless. If you use the web market (play.google.com) it'll still work for your phone.
I have tried restarting it a few times. Will try again though.
Did you have the same problem where upon loading the Market App, a webpage was opened showing Google Play terms and nothing else?
redfox05 is offline  
Reply With Quote
Old March 9th, 2012, 09:21 AM   #6 (permalink)
New Member
 
Join Date: Apr 2011
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

same problem here...got the market app, no google play app
and keep getting stuck on a policies page.
done reboots,factory resets and everything and still not working.
getting sick of the HTC now....never had so many problems on
a phone before.
phantom848 is offline  
Reply With Quote
Old March 9th, 2012, 09:28 AM   #7 (permalink)
Fixing stuff is not easy
 
Join Date: May 2011
Location: Over there <points>
Gender: Male
Posts: 7,690
 
Device(s): Samsung Galaxy S3; Asus Infinity
Carrier: Sprint

Thanks: 2,117
Thanked 4,314 Times in 2,513 Posts
jerofld
Default

Quote:
Originally Posted by redfox05 View Post
I have tried restarting it a few times. Will try again though.
Did you have the same problem where upon loading the Market App, a webpage was opened showing Google Play terms and nothing else?
For awhile, I wouldn't even get the policy page. The market just wouldn't load. My tablet was rooted so I was about to make a back up and manually uninstall the normal market and install the new play market manually when it started working. Once I got the policy page, I had to delete the data and reboot and it worked.
jerofld is offline  
Reply With Quote
Old March 9th, 2012, 09:40 AM   #8 (permalink)
New Member
 
Join Date: Apr 2011
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

sorted mine there now....

just follow the download link on this page, it will remove the old market and install the new google play app


Google Play Store update rolling out now – download it early | Android Community
phantom848 is offline  
Reply With Quote
The Following User Says Thank You to phantom848 For This Useful Post:
Googleplaycrap (March 9th, 2012)
Old March 9th, 2012, 10:49 AM   #9 (permalink)
New Member
 
Join Date: Aug 2011
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Exactly the same problem with my htc desire. Unfortunately because it is a very recently fixed phone, I have no file manager whatsoever on it (and obviously can't access the market now to install one!) so can't install the apk file I put on my sd card from the link above.

Has anyone got any more suggestions?
hootnow is offline  
Reply With Quote
Old March 9th, 2012, 11:28 AM   #10 (permalink)
Member
 
Join Date: Oct 2010
Posts: 358
 
Device(s): Galaxy Nexus I9250, Vibrant (retired), Galaxy Tab 10.1
Carrier: T-Mobile US

Thanks: 25
Thanked 62 Times in 51 Posts
Default

So bizarre. I had the Play Store icon for about 2 days, clicked it just now and nothing. Then I go to my apps and there's the Play Store but it has the old market icon, i can get to the play store from it. Also, this was right after I had exited the store, and my lookout scanned "google play store" again, meaning there was an update to it. So are they changing the icon back to the old one with the new name?
mrsbelpit is offline  
Reply With Quote
sponsored links
Old March 9th, 2012, 11:44 AM   #11 (permalink)
Junior Member
 
tyler79durdan's Avatar
 
Join Date: Mar 2012
Location: Michigan
Posts: 82
 
Device(s): HTC Inspire 4G
Carrier: Not Provided

Thanks: 6
Thanked 11 Times in 10 Posts
Default

Sometimes apps REQUIRE a wifi connection for a solid merge. Google play is a rebranding of market and would therefor require a merge. Maybe try using a wifi connection and retry your flashing steps with wifi enabled and streaming.
__________________
PHONE- HTC Inspire 4G running Ascension ICS
TABLET- Samsung Galaxy 10.1 WiFi
OTHER DEVICES- Prevail,S2,Droid X/2,EVO,Triumph,VS G-Tab,Precedent... ETC
tyler79durdan is offline  
Reply With Quote
Old March 10th, 2012, 08:31 AM   #12 (permalink)
New Member
 
Join Date: Apr 2011
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by hootnow View Post
Exactly the same problem with my htc desire. Unfortunately because it is a very recently fixed phone, I have no file manager whatsoever on it (and obviously can't access the market now to install one!) so can't install the apk file I put on my sd card from the link above.

Has anyone got any more suggestions?
did you download it via the internet on your phone?
if so then open the net again,
press menu,
then press more,
now scroll down to downloads.
when you click on the APK file it
will pop up do you want to install the file.
it sometimes takes two tries to get it to install
as the first time opens a agreement pop up
but doenst install.second time installs properly
and also removes any old versions of market.
phantom848 is offline  
Reply With Quote
Old March 10th, 2012, 12:29 PM   #13 (permalink)
New Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

ITS FIXED!!!!

Just to let you know, I turned on my phone yesterday, and the Market logo for the shortcut on my home screen has mysteriously changed, and 'Play Shop' now appears in my Apps Menu. (Market has now disappeared).

It appears that I have now been successfully changed over to the new Play Shop, and my old market shortcut on the homescreen now loads Google Play.

The first time I loaded this new app, I was asked to agree to some terms and conditions (Looked different to the one that flashed up for a split second when attempting to load the Market app during the problems. But it all seems to work fine now, and looks very similar to the old Market app layout to be honest.

I would suggest to people to wait it out, and restart your phone every so often, connect to the internet maybe, and magically your phone will hopefully be updated? Thats what happened to me

Good luck all!
redfox05 is offline  
Last edited by redfox05; March 10th, 2012 at 12:37 PM.
Reply With Quote
Old March 10th, 2012, 12:34 PM   #14 (permalink)
New Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

P.s. just to let you know there is a post about this issue on the vodafone forums:

Messed up Market to Google Play update - Vodafone eForum

Hope it helps.
redfox05 is offline  
Reply With Quote
Old March 10th, 2012, 12:40 PM   #15 (permalink)
Senior Member
 
saptech's Avatar
 
Join Date: Dec 2011
Location: Third Stone from the Sun
Posts: 3,677
 
Device(s): Motorola Moto G, Samsung Stratosphere, Galaxy Tab 2 SE.
Carrier: T-Mobile

Thanks: 610
Thanked 798 Times in 637 Posts
Default

I'm not sure if I had the problem or not. It seems maybe a week or so ago I noticed it was showing Google Play when it wanted to be updated, but I didn't know it, so I kept closing it out. All the while I wanted the Market.

Later that day I noticed the Market icon missing on my home screen, and I guess reading on AF about the new Play for market, I was able to add the Play icon to my home screen.

No problems since having it.

Thnx.
__________________
"I'm gonna put a curse on you and all your kids will be born completely naked" - Jimi Hendrix
saptech is offline  
Reply With Quote
Old June 12th, 2012, 05:12 AM   #16 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Cannot access Google Play

Hello!

Recently I have bought a new SD card for my HTC desire. I managed to make everything work as it should. But suddenly I have discovered that my Google Play application doesn't work.

The Google Play app actually opens up and I see the windows where app pictures should be, but there is only text and no pictures. I can search through the apps and select them, however there are no images. Furthermore, when I try to download the app, Google Play cannot download the app.

I have also discovered, that I cannot sign in to Google through android internet browser. It's funny, however, that my Gmail app works and I can receive emails. And when I try to access any of the google services this page shows up:

Web page not available The web page might be temporarily down or it may have moved permanently to a new web address.

I have already tried cleaning all cache and cookies in the Internet browser and cleaning data and cache from the Google Play app.

Does anyone have an idea what is happenning?

Please help!
cocktailmaster is offline  
Reply With Quote
Old June 20th, 2012, 06:38 PM   #17 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Not sure if this is the right place to post this, but I am a smartphone noob and this is driving me crazy. I have a Mesmerize (i500) through US Cellular, and I can access the App Market fine, but when I go on the internet to the Play site, I keep getting warnings about the certificate not matching something or other, and anything I've tried to install gets denied as not being compatible with my device. No app for Play, and apparently no apps from Play either. Any (easy) suggestions??
Lizbuppers is offline  
Reply With Quote
Old October 6th, 2012, 08:31 AM   #18 (permalink)
New Member
 
Join Date: Oct 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by jerofld View Post
Have you tried clearing data/cache on the new market? Settings > Applications > Manage Applications > All tab > Play Store > Clear data.
Hello Cannot access Google Play or Market although i have an activated google account when i tab upon google play apps i receive the following message ( Authentication is required. you need to sign into your google account )
abdosagor is offline  
Reply With Quote
Reply
Tags
desire hd, google play, google play business and program policies, htc, market, problems


Go Back   Android Forums > Android Discussion > Android Lounge
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:40 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.