Go Back   Android Forums > Android Discussion > Android Lounge
Android Lounge A place for general Android discussion and questions.

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old June 24th, 2012, 12:30 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2012
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Wifi Connection Problem

Hi I am new here and I have a problem. I have a phone Sony Ericsson WT19i with Android 2.3.4 and a wireless-g 2.4ghz Linksys router. The router seems to be working fine whenever my sister's iPhone or other laptops connect to it... The problem is whenever I connect my phone the router restarts and it keeps restarting every 1 minute(?). How do I fix this? Thanks.

nethoinkz is offline  
Reply With Quote
sponsored links
Old June 24th, 2012, 09:11 PM   #2 (permalink)
AF Addict
 
Rush's Avatar
 
Join Date: Jan 2011
Location: Loganville, GA
Gender: Male
Posts: 18,529
 
Device(s): HTC ONE
Carrier: Sprint

Thanks: 2,852
Thanked 3,106 Times in 2,336 Posts
Default

Welcome aboard. I'm not familiar with your device, but anyway..what steps have you done so far to get this issue resolved? Below are two things that you could do.

● Unplug the router for two minutes, and restart your device would be two good troubleshooting steps to begin with.
__________________
"Accept the things you cannot change, have the courage to change the things you can ...And have the Wisdom to know the difference".


Rush is offline  
Reply With Quote
Old June 25th, 2012, 10:30 AM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2012
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hmm. I think I tried that already. I tried using static IP even tho I don't really know what I'm doing..... I was able to make it work for 5 minutes. (although I don't remember which steps have I done)
Tried to mess around with the router's configuration.
-changed channels 1,6,11
-tried mixed, g only, b only
-tried automatic configuration-dhcp tried and changed to static ip as well

I don't know what else to do. x___X
My Phone is killing my Router whenever I connect.
nethoinkz is offline  
Reply With Quote
Old June 25th, 2012, 12:16 PM   #4 (permalink)
New Member
 
Weaksid's Avatar
 
Join Date: Jun 2012
Location: Altoona, PA - USA
Posts: 11
 
Device(s): Droid X 1st Gen, Motorola XYBoard 10.1
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

I've seen this before with just normal computers. It's usually caused by a overwhelming amount of data at once or sometimes if one of those programs transmitting has a bad packet. On the computer, I found the software that was causing it, removed it, reinstalled, and it worked fine after that. It was weird.

I would start with your router, reset it, set the wireless security up using WPA2-Personal , channel 9, and if you want to bump the security up to the next level, filter using device MAC. Keep the DHCP and other settings where they are at. I'm also assuming you have our router directly connected to your modem and not to another router.

Clear the saved connection in your phone, then re-add to see if it happens to reboot it again. If it does, might want to look at what apps you have on your phone. You may have a bad one or your phone could also be infected and it could be causing issues for your router. If you want to check your phone for virus/malware/etc, I recommend Bitdefender through the Android store. It will automatically scan your device and memory card.

If doing that doesn't work, could try backing up your phone then doing a factory restore. Start restoring pieces at a time, see if you come across the problem again. If you want to back up certain things, a program called Mobisynaps works great. Plus you can also select the options to back up all your application settings and data to your Google account located in your settings. If you need further instructions, I'll provide them.

Hope this helps.
Weaksid is offline  
Reply With Quote
Old June 25th, 2012, 01:28 PM   #5 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2012
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hmm. I'm gonna try that.... but... why channel 9 of all? Is there an explanation about this? I just wanna know. Thanks.
nethoinkz is offline  
Reply With Quote
Old June 25th, 2012, 01:33 PM   #6 (permalink)
New Member
 
Weaksid's Avatar
 
Join Date: Jun 2012
Location: Altoona, PA - USA
Posts: 11
 
Device(s): Droid X 1st Gen, Motorola XYBoard 10.1
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Channel 6 is used by default and I've noticed at least in the area around my work and home, a lot of people like to use channel 1 or some in betweens. You could do a survey of your area and see what channels most of your neighborhood is using and use one they aren't. Keep in mind that each channel overlaps total of 3 channels. I can't post links yet, but if you look for 802.11 channels in Google, you'll see what overlaps. There are also many images that show too for those that like images
Weaksid is offline  
Reply With Quote
Old June 26th, 2012, 04:38 AM   #7 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2012
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Didn't work.
For some more information.
-Internet is stable when my phone isn't connected.
-When I connect my phone it constantly resets and I can only use like 3-10 seconds of internet every reset. x_X
-I have connected my phone for more than 5min. (happened only twice/thrice)

Help me... any more things I could try? x_X
nethoinkz is offline  
Reply With Quote
Old June 26th, 2012, 08:53 AM   #8 (permalink)
New Member
 
Weaksid's Avatar
 
Join Date: Jun 2012
Location: Altoona, PA - USA
Posts: 11
 
Device(s): Droid X 1st Gen, Motorola XYBoard 10.1
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by nethoinkz View Post
Didn't work.
For some more information.
-Internet is stable when my phone isn't connected.
-When I connect my phone it constantly resets and I can only use like 3-10 seconds of internet every reset. x_X
-I have connected my phone for more than 5min. (happened only twice/thrice)

Help me... any more things I could try? x_X
Oh, your phone resets, not your router? The way it sounded, your router was resetting when you connected your phone to it.

*So, this may be a little confusing, but I just didn't want to delete what I already typed. I was searching for how to factory reset your type of phone and instead, I got a crap load of posts about the same issue you are having with that phone. It doesn't look like it's just with the WiFi, it's just rebooting in general. Everybody is calling them junk. Here is one link, talk[dot]sonymobile[dot]com/message/144906. Just do a Google search for "Sony Ericsson WT19i Restarting". There is a chance this could be a defect and a much bigger issue. *


In that case:
1) I would make sure your software is updated to the latest version released.
> To check to see if you have a update, go to Settings -> About Phone -> System Updates (This is recommended if you are not using a rooted phone) also found this -> sonymobile[dot]com/gb/software/

2) Double check Router and Phone settings.
Router = WPA2-Personal Encryption (Recommended), G-Only (As long as you don't own any wireless B devices), make sure MAC filter is disabled (want to make sure this isn't the issue), and that other devices can access the internet without issues with these settings.

Phone = OS is updated to current release for your phone. Delete your current connection with your wireless and recreate after router settings are correct. Also, make sure it's not somehow trying to attach to a open network around you.

3) If the above doesn't work and you haven't already did it, a good old factory reset may help.
Backing Up your Phone:
Google Backup = Settings -> My Accounts -> Select your Gmail account -> Make sure all items are checked for syncing (if you use these items). Settings -> Privacy Settings -> Check "Back up my data" and "Automatic Restore".

Factory Restore = Having a hard time finding instructions. If I come across them, I'll post.
Weaksid is offline  
Reply With Quote
Old June 26th, 2012, 06:40 PM   #9 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2012
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

No, sorry about the confusions. It is my router that resets...
Hmm.. I'm gonna do a factory restore when I upgrade my phone, but the problem is I don't know how... I wanted this.
nethoinkz is offline  
Reply With Quote
Old June 27th, 2012, 07:33 AM   #10 (permalink)
New Member
 
Weaksid's Avatar
 
Join Date: Jun 2012
Location: Altoona, PA - USA
Posts: 11
 
Device(s): Droid X 1st Gen, Motorola XYBoard 10.1
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by nethoinkz View Post
No, sorry about the confusions. It is my router that resets...
Hmm.. I'm gonna do a factory restore when I upgrade my phone, but the problem is I don't know how... I wanted this.
Okay, then I would say it's something on your phone causing it.

For Factory Reset, you could try to following: (I know it's not your same model, but it may work). Remember to backup your data first. To go with the ROM you're looking at, I'm pretty sure you go through the same menu for the system restore. Haven't did it for over a year. Hope the following helps.

(Copied from Knowyourmobile[dot]com)

First, try this:
  1. From the main home screen, tap menu
  2. Tap Settings, then Privacy
  3. Tap Factory data reset
  4. Tap Reset phone
  5. Enter your password if required, then tap Erase everything to confirm
If that doesn't work, or if your phone is frozen:
  1. Turn the power off. If your Sony Ericsson Xperia Arc is frozen, pull the battery out and reinsert it
  2. Hold the Left and right buttons located beneath the display
  3. Press and release the Power button
  4. Follow the on-screen instructions to hard reset your phone
Weaksid is offline  
Reply With Quote
sponsored links
Old June 29th, 2012, 04:52 PM   #11 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2012
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Didn't work. Probably my Phone's wifi is incompatible with my router that's why my router is malfunctioning?
Sorry for late response rooted, unlocked and installed custom kernel on my phone thought it would make a change... I wonder if custom rom would work. x______X
nethoinkz is offline  
Reply With Quote
Old June 29th, 2012, 08:50 PM   #12 (permalink)
Junior Member
 
Join Date: Jun 2012
Posts: 25
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 8 Times in 2 Posts
Default

Maybe you can try different firmware for your router, you might want to look if your router supports DD-WRT or Tomato. Those are custom firmware that fixes a lot of software related problems (I got greater range and stability using tomato on mine)
cvms100 is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Discussion > Android Lounge
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:20 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.