Go Back   Android Forums > Android Discussion > Android Lounge
Android Lounge A place for general Android discussion and questions.

test: Reply
 
LinkBack Thread Tools
Old July 1st, 2012, 03:02 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default adb not showing device

I have just purchased Android mobile ( Karbonn A1 model ) with Android 2.2
I rooted the device successfully. I have downloaded Rom Toolkit, Busybox, X-plore and other tools. The company has not given any driver. In windows 98 USB driver of my old java mobile allows me to copy/from sd card. However, I have tried three generic drivers for Android mobiles on Microsoft Vista 32 bit SP1, none works. I have installed android sdk. But adb devices does not show any device. I was using web server on my desktop to copy/ from my desk to mobile.
I modified build.prop to show diff. model. Unfortunately the build.prop I copied was showing Android 2.3.6 and my actual device has 2.2 When I reboot the mobile, not only Google play stopped working but all my apps, i.e. terminal emulator, X-plore etc. stopped working. Fortunately Build.prop editor app is working. I have restored all the correct values. But even after booting using Rom toolit ( Free version ) the problem remains. ( Google play and most of the apps not working + my internet is also not working.
So, now it is very urgent that I shall be able to push my old build.prop which I have saved on my desktop as well as on sd card to the systems folder and reboot. I hope it will work. May be I have to install google play and other apps again.
But I can do that only using adb and it is not working.
When I plug in USB cable it shows this device can work faster message ( I do not plug in in USB 2 interface ) and then the autoplay will be displayed for the CD Rom device ! ( windows show it not as USB storage device but cd rom ) and adb reports no usb and device is noI listed. I have read somewhere that USB device id must be written to some file. But I do not know how to get the value and write to which file ?
Please guide me how to connect to mobile using adb
Thanking you

Advertisements
maheshchavan is offline  
Last edited by maheshchavan; July 1st, 2012 at 03:11 PM.
Reply With Quote
sponsored links
Old July 2nd, 2012, 02:43 PM   #2 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I GOT IT WORKED ! I downloaded Zte n721 USB driver for my mobile. ( It requires speecific driver for your device. Google usb drivers works for very few mobiles. ) Then I put vender ID for Zte 0x19d2 to my adb_usb.inf. ( You can not save in edit but you have to use :
echo 0x19d2 >> adb_usb.inf ( use your vendor id you can get it from net I got it from mypcdrivers.com)
When you allow debugging on the mobile, it works.
maheshchavan is offline  
Reply With Quote
Reply
Tags
adb usb driver no device


Go Back   Android Forums > Android Discussion > Android Lounge
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:31 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.